After April update: Kodi has HW acceleration / rendering problems

This is the log:
https://paste.osmc.tv/pilagakoje

This doesn’t look right:

failed to configure renderer

Have you confirmed if you get this with all clips, or just some?
You have analogue audio enabled. Are you using the 3.5mm output?

Can you play 1080p Big Buck Bunny clip without issue for example?

Sam

It’s not every clip, a few are working but the most clips doesn’t work

No, I use the digital output. I didn’t configure it, because I was just testing the video output.

I tried to play it, but it’s the same issue I mentioned above.

Configure your audio first. This is recommended in the manual that you should’ve received with your device.

Can’t think of anything off the top of my head that would introduce a problem with the April update.

Sam

Hi,

I’ve got exactly the same problem after I updated to april update.
Everything worked great with the March update.
I am using HDMI through a receiver.
As soon as I disable hw acceleration it works.

Best regards

Hi,

please provide logs details can be found here

Tom

Are you using a Vero 4K?
Logs are really needed to see what’s going on.

Yes im using a Vero4K. I bring you some logs tomorrow, it’s the middle of the night where I live.

Same here :wink:

Looking forward to the logs.

Sam

ok, I tried a lot, but I can’t get it working.
It’s always the same: The march version is working and with the april version I get this issue.
And I don’t have time to search much longer for the reasons.

The only option I see, is to stay on the march version. Perhaps I can block this update, so I can at least update the rest.

But as I just bought the vero4k it’s a little bit frustrating. The years before I had the raspberry pi 1 and I never had any issues with osmc.

If this is an issue it will affect other users. In this case it will almost certainly be picked up and fixed in the next update.

You definitely need to reconfigure your audio settings from the look of your settings, if you are not using analogue audio.

Sam

These settings are the result of reinstalling osmc perhaps 10 times. I definitely use other audio settings on my “productive” system. But if you install osmc that often, you just look if the video is playing and not if all settings are correctly set.

I really hope if there are other users with this issue. Especially as the problem affects even the Big Buck Bunny clip.

I also encounter this problem but then with blu-ray files with the April update.
The movie starts but after 30 seconds or so the movie will slow down, starts buffering and the screen goes black with, also sound is gone.
When I try to play the same file with my Shield running Kodi 17.1 it plays fine. Didn’t encounter the problem before the April update.

Will try to upload the logs ASAP but the wife has taken over the remote.

I want to go back to March version but don’t have a micro-sd:disappointed_relieved:
Is there any way to go back to the March version without SD???

Hi,

At last, here is the log.
https://paste.osmc.tv/ajokayegep

Hope you can find anything that is wrong.

Hi Schedvizz,

    20:32:36.149 T:4110229504   ERROR: GetDirectory - Error getting nfs://192.168.1.3/volume1/
    20:32:36.149 T:4110229504   ERROR: CGUIDialogFileBrowser::GetDirectory(nfs://192.168.1.3/volume1/) failed
    20:32:38.969 T:4110229504   ERROR: GetDirectory - Error getting nfs://192.168.1.3/volume1/
    20:32:38.969 T:4110229504   ERROR: CGUIDialogFileBrowser::GetDirectory(nfs://192.168.1.3/volume1/) failed
    20:32:43.039 T:4110229504   ERROR: GetDirectory - Error getting nfs://192.168.1.3/volume1/
    20:32:43.040 T:4110229504   ERROR: CGUIDialogFileBrowser::GetDirectory(nfs://192.168.1.3/volume1/) failed
    20:32:44.612 T:4110229504   ERROR: GetDirectory - Error getting nfs://192.168.1.3/volume1/
    20:32:44.612 T:4110229504   ERROR: CGUIDialogFileBrowser::GetDirectory(nfs://192.168.1.3/volume1/) failed
    20:32:45.375 T:4110229504   ERROR: GetDirectory - Error getting nfs://192.168.1.3/volume1/
    20:32:45.375 T:4110229504   ERROR: CGUIDialogFileBrowser::GetDirectory(nfs://192.168.1.3/volume1/) failed
    20:32:50.859 T:3883660272   ERROR: Unable to lookup host: ''

Seems to be having issue with software mounted nfs shares, not sure why its only become an issue with the latest update. Could you try playing the file back locally either the sdcard or from a usb drive. Advise if there is still an issue when hardware acceleration is enabled?

If this helps, you should consider kernel mounted nfs shares via fstab; as it gives better throughput. If you advise the device the nfs shares are on, I try provide further instruction for setting these up.

Thanks Tom.

Okay.
I take and try play via USB and see if there is still a problem with hw acceleration.

I have all my movies on a Synology NAS by the way.

Thanks for now.

There is also the

failed to configure renderer

Sam mentioned above.
Maybe there is something wrong.

Hi newsy,

I seen that as well, but as the nfs errors aswell, wanted to investigate issue my getting a local playback.

Thanks Tom.

Hi Schedvizz,

If playing back locally helps, nfs kernel mounts:

This guides a bit out of date, so I think the fstab needs to be:

yourip:/volume**/nameofshare /mnt/nameofshare nfs nouser,x-systemd.automount,auto,ro,dev,exec,suid 0 0

** volume 1 or 2

to add the video source you browse to the root file system, mnt and nameofshare

Thanks Tom.

After making my first post in this forum just a bit ago and then reading this discussion, I noticed that my debug log also has several “failed to configure renderer” as well. Perhaps my issue is similar(?) as my problem started pretty recently as well. Here is the post: