After April update: Kodi has HW acceleration / rendering problems

Sorry if I’m unclear, today when I tested with adjust display refresh rate activated on start/stop the movie played just fine. The problem occured first when I stopped the movie.


And what was it on before, Always or off?

Also please advise on the other settings under: Settings, player?

@newsy seems I may have jumped the gun here, Could you please advise what you have adjust display refresh rate set to. It would also be interesting to know the other settings under: settings, player, are?

Thanks Tom.

The strange thing it was set on the same setting the other day when it did not work when I started the movie.

Sure I gonna check that.

Please can you tell also the origin of your files
For me Vero4 user

  • 100 % of DVD ripped files works
  • more then 95 % of “TNT” (DDT Live TV) recorded files works fine.
    For the others I’ve issues also.
    Please tell us, more.

I got problems with my blu-ray rips in mkv format. Can try a regular avi rip tonight.

It seems that I have a workaround to get movies playing.
If I use the osmc remote, browse the library and start the movie. Then immediately (maybe after 3 seconds) I press the “back” Button on the remote (the one with the arrow; the first of the six lower buttons).
So the movie keeps playing but you are back in the library.
And then I click once more on the movie, so it starts again. But then the movie is playing without any problems.
The problem is, I have to start every movie twice.

The other option is to deactivate the “Allow hardware acceleration - amcodec” then the movie is also playing, but I think it’s not so fluent.

The adjust display refresh rate is set to “off”
Changing this option doesn’t solve the problem.

Sync playback to display - off
minimise black bars - off
display 4:3 video as - Normal
Enable HQ scalers… - 20%
allow hardware acceleration - on

  • mpeg2 - always
  • mpeg4 - hd and up
  • h264 - always

I’d like to add that I have this exact problem.

When trying to playback a seemingly random selection of MKV files with H/W Acceleration enabled I get a black screen with ‘Buffering…’. Disabling H/W Acceleration fixes playback straight away.

My Vero 4k is new (previously using a RPi without issue), so I didn’t use any versions prior to April, so I don’t know if it was the April update that caused this.

I don’t have any logs to hand, but I can try and pull some if it will be of further use?

Does this happen with all files or just some?

That’s a very interesting question…

It consistently happens with a specific subset of files, however there are other files which may (or may not) experience this issue and a larger set which have no issues.

Can you give me MediaInfo on those problematic files?


Here you go: GeneralUniqueID/String : 239604950459925757676656141896220857 -

The first 3 never work, and the last 2 may or may not work.

Thanks. I think it’s the high number of reference frames causing this issue. I’ll look in to it.


Interesting, I hope you can find a solution! :o)

Now I have tested for a few days and I get problems with the film spools and picture goes black at random. And this happens both with hw acceleration turned off and when it is enabled. When I test the day after, it all of a sudden work as usual. No problems at all. One thing I noticed yesterday was that Vero box was very hot, almost as it burned out. And the film stopped and I got the sad face. So I wonder if the problem can be related to heat?
Its so frustrating when the problem is random. Sometimes it works and sometimes it not.
And I didnt experienced this with the Mars update.

If you reinstall the March version, does the problem go away?


When I try to install March update with an SD card it doesnt work. I follow the install instruction but it does not know of the sd card, when I turn on the box It starts up as normal. Have tried with different sd cards

Try holding in the SD card, or checking that it is inserted properly.
There is some information on reinstallation here: Reinstalling OSMC - Vero 4K - OSMC.

It is the guide I followed. I have also tried to keep the sd card inside without success. It clicks when I stop in there but it is not fixed but is very loose. Can try again tonight.

How do I know that it sits right. I think I do it right but I could do wrong.

See System wipe issues - #5 by sam_nazarko

Thanks Sam, gonna try tonight.