After April update: Kodi has HW acceleration / rendering problems

Hi Schedvizz,

    20:32:36.149 T:4110229504   ERROR: GetDirectory - Error getting nfs://
    20:32:36.149 T:4110229504   ERROR: CGUIDialogFileBrowser::GetDirectory(nfs:// failed
    20:32:38.969 T:4110229504   ERROR: GetDirectory - Error getting nfs://
    20:32:38.969 T:4110229504   ERROR: CGUIDialogFileBrowser::GetDirectory(nfs:// failed
    20:32:43.039 T:4110229504   ERROR: GetDirectory - Error getting nfs://
    20:32:43.040 T:4110229504   ERROR: CGUIDialogFileBrowser::GetDirectory(nfs:// failed
    20:32:44.612 T:4110229504   ERROR: GetDirectory - Error getting nfs://
    20:32:44.612 T:4110229504   ERROR: CGUIDialogFileBrowser::GetDirectory(nfs:// failed
    20:32:45.375 T:4110229504   ERROR: GetDirectory - Error getting nfs://
    20:32:45.375 T:4110229504   ERROR: CGUIDialogFileBrowser::GetDirectory(nfs:// failed
    20:32:50.859 T:3883660272   ERROR: Unable to lookup host: ''

Seems to be having issue with software mounted nfs shares, not sure why its only become an issue with the latest update. Could you try playing the file back locally either the sdcard or from a usb drive. Advise if there is still an issue when hardware acceleration is enabled?

If this helps, you should consider kernel mounted nfs shares via fstab; as it gives better throughput. If you advise the device the nfs shares are on, I try provide further instruction for setting these up.

Thanks Tom.

I take and try play via USB and see if there is still a problem with hw acceleration.

I have all my movies on a Synology NAS by the way.

Thanks for now.

There is also the

failed to configure renderer

Sam mentioned above.
Maybe there is something wrong.

Hi newsy,

I seen that as well, but as the nfs errors aswell, wanted to investigate issue my getting a local playback.

Thanks Tom.

Hi Schedvizz,

If playing back locally helps, nfs kernel mounts:

This guides a bit out of date, so I think the fstab needs to be:

yourip:/volume**/nameofshare /mnt/nameofshare nfs nouser,x-systemd.automount,auto,ro,dev,exec,suid 0 0

** volume 1 or 2

to add the video source you browse to the root file system, mnt and nameofshare

Thanks Tom.

After making my first post in this forum just a bit ago and then reading this discussion, I noticed that my debug log also has several “failed to configure renderer” as well. Perhaps my issue is similar(?) as my problem started pretty recently as well. Here is the post:

Hi @pab1

Can you confirm if your Vero 4K behaved fine before the April update?


Hi Sam - sorry for any confusion but mine isn’t involving a Vero 4K. I saw that this post discussed rendering problems, saw the reference to something in the logs above that I have a number of in my logs, and thought they might be related. But, I will add that mine is a relatively new occurrence (like in this discussion) in that the movies that I am having problems with now played perfectly prior to this issue (They played great approximately 2 weeks ago - not sure when the problem occurred after that but their not playing great now).
Hope I didn’t hijack this thread. Not my intention.


Now I have tested the same video locally via USB hard drive and get the same problem when I have HW acceleration enabled.
It becomes black screen, buffer and changes the sound of the amplifier from DTS to stereo.

Here is the log.

Best Regards


Thanks for confirming it was it wasn’t a network issue, I’ve been through the logs and the error does indeed appear to be the same as newsy’s.

Please advise how your audio is configured on the vero4k, or a screenshot.

Thanks Tom.

I set some update packages “on hold” and updated only the rest. I need to confirm it, but it seems to me as if the problem is not in the “mediacenter” packages, rather in the “kernel” or “vero-image” package.

To be precise:
I thought the problem would result in updating the mediacenter, but as I “apt-mark hold” the packages containing “mediacenter” in its name and updated the remaining packages the error occured anyway. So maybe it’s one of the other packages.

My audio setup is:

Audio output device: AML-M8AUDIO,HDMI
Number of channels: 5.1
Output configuration: Optimized
Stereo Upmix: active
Send low volume noise: not active
Allow passthrough: active
All audio modes are active (Dolby, DTS etc)

Everything works great when HW acceleration is not activated.


if you set adjust display refresh rate to: off. Does it make any difference?

Thanks Tom.

Now it worked all of a sudden. But you’re probably on the right track for adjust display refresh rate it appears to be malfunctioning.

Now I got the problem when I stopped the movie and would return to the menu. Jumped back and forth between black image and standard image.

Here is the log for this time when the movie played back just like it should.

Maybe it is the same problem people have with there vero2 blank video at playback?
Far-fetched maybe.


I think this to be expected, as the menu and video have different frame rates and auto adjust has been disabled.

Thanks for trying this, this could possibly be the cause of the issue. I think it needs testing on another device to confirm.


I’ve been through your logs again and I’m seeing this:

06:37:58.387 T:2348807152   DEBUG: CDVDClock::ErrorAdjust - CVideoPlayerAudio::OutputPacket - error:-22525.872176, adjusted:-22525.872176
06:38:08.120 T:2348807152  NOTICE: CVideoPlayerAudio::Process - stream stalled

Does setting adjust display refresh rate to: off. Show any improvement?

Thanks Tom.

But that problem occured when it was activated not disabled.


Sorry I’m confused now, what setting of adjust display refresh rate; when videos were working:

On Start/stop.

I thought you had set it too off?

Sorry if I’m unclear, today when I tested with adjust display refresh rate activated on start/stop the movie played just fine. The problem occured first when I stopped the movie.