After February's Update Pulse-Eight CEC Adapter fails to initialize

Hoping for some help, did the update tonight on my Vero 5 and after I noticed a error popup in the right hand corner. I used the log uploader to capture some logs Haven’t figured out much out yet, I saw some mention to try changing cables as far as I know all my cables are CEC certified and everything was working before the update. Going to power off all my devices Tv LG C2, Onko AVR TX-NR-5100 and the vero 5 and turn them on again.

I went down stairs and powered everything off at the mains and this seemed to fix it. Great … then I tried a restart of Kodi/OSMC and the CEC error came back. I managed to upload a log of when it was working after a power reset at the mains.

this happens every time the Vero 5 restarts. As of right now the only fix I have come up with is, power down all devices at the main power and turn it all back on. Everything seems to detect and work fine until the next restart of OSMC.

Can’t think of what would have changed significantly in CEC to cause this but I am sure we can get to the bottom of it.

If you go to Settings → Input → Peripherals → CEC Adapter, is the device configured as a ‘Player’ or a ‘Recorder’?

Many thanks


I have never even looked in those settings before, it was set as Recorder. Interesting today I noticed I was having issue with my Rogers cable box so I went and turned off the CEC in the settings on the cable box. I noticed when I went to check this setting out for you I tried a restart of the Vero 5 and noticed I didn’t get the CEC error. So I went back and turned on the CEC on my cable box and the next reboot the CEC error is back. I’m not experienced with this CEC stuff as I just upgraded my AVR and TV just before purchasing the Vero. In the past my harmony one device handled all the on/off and inputs but the remote is getting old.

No one is experienced with CEC per se. It’s a dark art.

I have some ideas on how we could proceed further but before doing so,

Can you make sure the TV firmware is up to date?

Can you power everything connected to that TV off for 10 mins?

If the issue persists can you try with only the Vero connected and see if you can reproduce the issue?