After installing new update (2017-03-22) - Welcome to emergency mode!

I have just uploaded osmc and now on the screen is the following:
Welcome to emergency mode! After logging in, type “journalctl -xb” to view system logs, “systemctl reboot” to reboot, “systemctl default” to try again to boot into default mode.

The problem is ssh is not working and I don’t have usb keyboard.
What are my options?

Buy another SD card or powersupply, or ideally both.
Your post history: “read only mode” suggests you may have faulty peripherals

Power supply i original raspberry pi’s one.
SD card is samsung evo+.
Everything worked until the update.

I borrowed an USB keyboard from the neighbour. :blush:
Where should I look for what?

You need to reinstall. We can’t guarantee the integrity of the filesystem, so even if we ‘repair’ things to a reasonably workable state, there may be subtle corruption.

And I suspect your SD card may need replacing.

Should I do the fsck before?

OSMC already does this.
If it can’t repair it, then you have serious corruption.

Just get another SD card and reinstall. Take regular backups using My OSMC in future.

Have you changed SD card driver?

No. Your card is likely borked, it is that simple.

OK, I will try to reinstall. :cry:

You likely can’t reinstall to the same SD card.

At first I will try to see what windows are saying about this SD card. Then I will try to reinstall osmc.
If windows are recognizing the card as the valid one but osmc doesn’t, then something has happened with the osmc update.

No. That’s not necessarily true.

I am telling you that we didn’t change anything re SD cards. 4 days ago, before the update, you already had problems with ‘Read-only’ mode on your SD card. Do you think this is a coincidence?

It will be recognised, but I suspect writes won’t work properly. You can use H2Wtest if you don’t believe me.

When you say “read only mode”, to which post you are referring?

This post that you wrote four days ago.

That was the other pi - RPI2.
Now I am talking about RPI3.

I found the cause of the problem.
I have an external USB drive that is all the time connected to the RPI3.
Before update, I have unplugged it.
After update, during boot, I have seen complains that an external usb drive is missing.
After this message, it is counted 1:30 minutes, and afterwards I got the original message and shell prompt.

Now I opened /etc/fstab and added nofail option to the external USB drive in question.
After that I have rebooted the system and OSMC works as it used to do.

I hope this will help to someone in the same situation.
Sam, thank you very very much for your cooperation.

You can also remove it from /etc/fstab. It will be mounted reliably in /media.


It used to be a problem in the past, but maybe I should give another chanse to the /media folder.


fyi, I run in the similar situation. March 21 when I read the blog that the new update is available I checked at home if it is ready for download. I have RPi3, running from usb stick. No indication that the update is available. Then I manualy check (in MyOsmc) for the update. Nothing happened, even no bar that the system is checking if the update is available as before. Therefore I decided to reboot the system and the system ended in emergency mode. Booting stops at the moment trying to mount mmcblk0p2. I have to state that so far the system have been running without any problem, I didn’t make any change before that as kiticar. Maybe SD card died but booting process normaly starts and I am running the system from usb stick, not from SD card.
Is there any option how to make a transfer of the settings to new installation or to make a back up it this emergency mode? The files on usb stick or SD card are normaly accesible but I am not linux expert. Thank you.

You can keep all your Kodi settings by keeping a copy of /home/osmc/.kodi (it’s a hidden folder, so be sure to enable view hidden files/folders to see it).

As for why the device won’t boot, it sounds like the device on which mmcblk0p2 resides is faulty. This is probably your SD card.

As you boot from USB, you may be able to setup a new SD card, go through the initial setup with it in the pi, and then change the /boot/cmdline.txt to set it to boot from USB and your USB card should remain untouched and everything should be as before.