After July update, transmission now says "permission denied"

I searched and found a thread about this from 2015 that recommended using SSH to run

sudo usermod -a -G osmc debian-transmission

But I just get a message saying that user debian-transmission does not exist.

Did something happen in this update that changed permissions for mounted USB drives? My external HDD is auto-mounted on /media.

I’m using the transmission daemon service installed via the MyOSMC app store.

Thanks for your help!!

Nothing changed in my transmission after july update, no “permission denied” anywhere. Only difference is that I have a fstab mounted drive in mnt, not automount in media.

Hmm… Should I not be using automount for my USB external HDD then? I don’t know how to test that. Would you mind taking a newb through the steps to mount the drive to /mnt instead of /media?

Thanks again!

Download putty if you use windows and connect with ssh. You must know IP of your Vero. Username and pass are OSMC
First make a directory under /mnt. Lets call it mySharedDrive.

type sudo mkdir /mnt/mySharedDrive
then run ; sudo nano /etc/fstab

Then add a line to fstab like this

UUID=uuidofpartition /mnt/mySharedDrive ext4 defaults,noatime,auto,nofail,x-systemd.mount-timeout=30 0 0
save end exit ctrl-x

Type blkid at the command prompt to get the value of uuidofpartition.
If you have any problems with above, I will be glad to help you

Thank you for the reply! I noticed you specified ext4; my drive is NTFS (I periodically move it to a windows machine to transfer larger files), does that matter? It hasn’t been an issue with anything so far.

Yes, instructions are for ext4, for ntfs you should replace ext4 line with ntfs.

Yup, it was that. After the july update I guess you can’t have transmission write to anything on /media.
Or at least that’s what it was for me.

You changed it to /mnt? Now is working?

Yeah, changing it to /mnt fixed it. Thank you!

Where to start?
So, my setup ; Raspberry Pi 3, attached a USB storage 1TB, OSMC installed ( latest Version) and Transmission installed the MyOSMC app store ( including using transGui). Ow and Samba ( don’t ask me why, guess someone somewhere suggested it as a solution)
Initially I had an NTFS partion running with all kind of tvshows which was accessible on my home network ( read TV and pc’s) , I formated the thing to Ext4
The problem now is that I needed some file transfer in case I want to add / remove shows. But I thought I could simply add transmission and get the shows right on the drive. I was holding that thought but in practice my fingers bleed, my head burns, the veins pulsate … in short I can’t get it to work.
I tried the above and guess what, it created a localshare named mySharedDrive. but now ( over the browser interface)…in Kodi the Auto-mounted drive doesn’t appear anymore and transmission is killing the connection … FUBAR or PEBCAC
if you could help me a hand here I would be grateful
***Update … the transmission Part seems to be working… now how to make it visible in Kodi?
****Update … checked the TV all is fine , working like a charm , time for some medicine