After latest OSMC upgrade, library reverted

So after the latest upgrade of OSMC on my Vero4K, my library seems to have reverted to an earlier state where many of my movies and tv-shows are missing, the watched state of these reverted as well. After updating the library, many of the movies and tv-shows are still missing. Don’t know why a library update wont pick up these.

Have compared with my libreelec installation on my Rpi3 which still works fine. Since they share mysql database I looked in the logs and it seems like after the update my osmc installation uses the database named MyVideos116 and libreelec uses MyVideos107.

Why did osmc switch database after the upgrade? And why isn’t it able to pick up all movies and shows when trying to update library? And is there any way I can revert to using MyVideos107 database on osmc to get back to how things were before?

Most likely you have tried a Kodi 18 version earlier at wish time the database was migrated and you then reversed back to Kodi 17. If you now still have the Kodi 17 databases that are more actual you can delete the Kodi 18 database and restart then it will be recreated using the data in the Kodi 17 database.

But also a warning if you use a central database you need to ensure all devices are using the same Kodi version otherwise you run into problems.

1 Like

Thank you! That worked!

Hope you did it to all databases not only the Video one?
Also as mentioned you then also need to upgrade your librelec to Kodi 18 as otherwise it will use the old database

Yep, music database also fixed. And on my way to upgrade libreelec.