After March 2022 update videos stutter

After I installed the March 2022 update (hardware: vero 4k 2017), movies/videos from my external hard drive (intenso - 2tb) started to stutter and I am not any longer able to watch videos. I’d be grateful for any constructive help. Best Cedric

Hi Cedric, by your description I’m taking it, that files that were stored and played from the drive before the update are now stuttering? Or is it new files?

No matter, there is stuff not mentioned in your “problem description”, like what is the filesystem on the 2tb drive, has the drive changed port, is it self powered or is there a powered hub in between the drive and vero4k? Have you tested the drive in windows, looked at smart data?

Before most of the common problems are eliminated I can’t really help, not even make a guess.
So I would restart the Vero, enable debug logging, restart the Vero, navigate to a problematic file, play it, let it stutter a bit. press stop. Disable debug logs, reboot Vero, Setting-MyOSMC-LogUploader, enable All, then upload selected logs. Then paste the URL here and we can have a look at the problems your system are having

Hi Joakim,
first of all, thanks for your immediate response. Here are some additional data:

  • filesystem on external drive: Mac OS Extended (journaled)
  • changed port? What do you mean?
  • self powered, yes
  • smart status - I don’t know. Can’t check smart status on a Mac (but first aid did not find any flaws on the hard drive).

I will try to do the more compliacted stuff you mentioned later.


Please post some logs

After some quick goole-fu, the Inteso 2tb I’ve found is a usb3 drive, with just 1 cable. Since USB3 can provide more power per connected USB-device, no more is needed. But the Vero is USB2, and the fact that you managed to run it for a while means you have been “nibbleing” at the max power output of the Veros PSU, and I’m guessing that the unit has become more and more “unstable”.

So what I meant with self-powered is that the storage unit has it’s own PSU. It has been said more then 100 times that you need a powered USB-hub, or HDDs with their own PSU. Since Vero4k(+) is USB2, it doesn’t reliably provide enough power for most hdds.

I copied the movie onto a USB-Stick and tried to play that movie from the USB-Stick (connected to the Vero4k). There were the same problems concerning stuttering. So I conclude that it has nothing to do with the external hard drive.

Later these days I’ll try to get some logs and to post them here.

The logs should give us some guidance.

Okay, done. Here is the URL: vutaviyaye

or (without a space)

Could you already have a look at the log data?

I see that the drive is formatted HFS+. It would be as better test if you can test from a drive formatted with EXFAT instead.

Also, I see that the video you tried to play was processed with Handbrake. While Handbrake is a great tool, it’s also a great tool for destroying video files. Do you have any examples that were not processed with Handbrake?

Thanks for your analysis bmillham. I always used this external hard drive formatted in HFS+ with no problems at all. Moreover, most of my movies were processed with Handbrake, but again I never experienced problems playing those neither on Vero nor on the computer.

Hi Sam, any news on the logs I posted?

Sorry, missed this. I’ll look at these tomorrow.



Hi Joakim,
any news on the logs I posted?

Hi Cedric

Sorry for being quiet for a while, my initial thoughts where that you where experience something simple as “early fatigue” of the Vero PSU, since from what I’ve understood you have had a USB3 based HDD connected to the Vero USB2 port. It often proofs to be a bad idea, with instability or other “unexplained stuff”. But it does put a a continues high load on the PSU, and those are like every human being, individual. Some handle the stress better then others.

The filesystem of choice for you is out of my comfort zone, so I wont comment on it, if it works fine.

When you upgrade the OS, you change some of the dynamics. There can be, and often is, a change in the power requirements of the device. Now I’m not talking about huge changes, but if you are taxating your PSU close to the max, any change will have perceived effects.

After glancing at the logs(and I’m no log expert, just love the sound of my own voice/typing :wink:), it is still my thought that there is something causing timeouts between videodata media and the video-processing, caches run dry, ergo lag spikes. If it’s due to power demands being at the edge of Vero PSU, or other reason that the USB bus as I understand it in this case has a hard time getting the data to processing, which might be possible. As I said, I haven’t really went through your log with a fine tooth comb, since I don’t have that experience.

This would have shown in the log, I bet, and it’s not a way of me trying to belittle you, rather me eliminating stuff from the top of my head. But have yo disconnected the HDD when trying another USB media, is it USB2 pendrive?

All this text is due to “semi high on fever”, so bear with me. I bet @sam_nazarko Sam will chime in when he gets a few secs to spare.

Time for another round of paracetamol and back to bed, good luck.

Hi Joakim,
thanks for your elaborate and helpful hints. Get well soon.


I’ll follow up on this shortly.


Hi Sam,
any ideas?


Hi, just for your information, me and a friend hat the same issues at Vero 4K.
I’m playing FHD and 4K MKVs from a Windows file share. All fine with 2021-12, with the 2022-03 version, it’s stuttering. Going back to 2021-12 with all the same settings, fine again.


I’ve sent you both an invite to a new video stack you can try which should solve this issue.