After moving to new window10 PC ' unable to connect to network server'

My setup was running perfectly until I had to replace my PC.
I gave the new PC same IP and name
But the shared forder on my pc can no longer be accessed
I tried to correct the conection to the PC in Kodi and I can browse to the correct folder, but cannot see the content.
for the other folders I have shared in the past, the path looks OK but also I cannot reach the content
I keep getting error 2 location not available!

I had similar issues in the past and the I documented what I did but I see no diference with that docuement

Upload full logs via MyOSMC for us to start to help

I Have no clue how to get those logs and where they are.
I have no real linux knowledge, so I am lost in the dark. :crazy_face:
I do not even know how to acces the box appart from the the TV screen :S
Sorry if my English is some weird, I am not native speaking and its a bit rusty

You can do it from the TV Screen, therefore we give you the MyOSMC tool.

  • upload the log set (all configs and logs!) using the Log Uploader method within the My OSMC menu in the GUI

  • publish the provided URL from the log set upload, here

You should find the MyOSMC menu either in your main screen or under settings

Hi @fzinken
That is a smart solution.
I uploaded the file to mivavaciye

Well generally it is not recommended to use names for smb, you might want to switch the name in the sources to an ipaddress

2021-11-22 16:19:43.662 T:4068020240   ERROR: SMBDirectory->GetDirectory: Unable to open directory : 'smb://USERNAME:PASSWORD@armani/sf/sf'
                                            unix_err:'2' error : 'No such file or directory'

But overall it seems more an issue of the structure of the shares on the windows machine as it looks some files are still working

2021-11-20 19:50:15.777 T:4065878032  NOTICE: VideoPlayer::OpenFile: smb://armani/movie/4K/Tenet.2020.mkv
2021-11-20 19:50:15.782 T:3648024800  NOTICE: Creating InputStream
2021-11-20 19:50:15.872 T:3648024800  NOTICE: Creating Demuxe

So suggest to check if all shares are configured as defined in your sources file.


I also have tried direct IP addres, but with same result.
On kodi side it had worked for many months.
I had to replace my PC (mainboard) And because it was already older I decided to have a new PC.
Installed an new win10pro and when I had basic things like mail etc running I transferred the drives to my new PC.
Created a kodi account on that PC
I have setup sharing for advanced sharing and added kodi with full access to the complete HD
I also kept the same shared drive name that I used in the past hoping that all would work smooth and that I would keep de ’ watched’ markers
I tried all above paths with the same result:(

I see now on my old system that i had SMB1.0/CIFS client enabled On the new system it is not.
tried thins but still no workingsolution.

In windows 10 you must connect with the account.

share the folder on windows 10 and add your local account in to the share permissions, for example “simon”.

Then when you add the share you add the smb://user:pass@armani/movie

If you previously had shares set up try change the ip address of the windows PC and resetup the shares.

edit: actually you don’t have to add the account to the share permissions, you can leave it on everyone read access. But you must connect with the local account. Guest access was disabled by default. Can enable it with reg key but not recommended.

This is something that should NOT be done. Doing this stores your credentials as a fixed thing for every item in your library. It will also make your password show up iin your logs. The way to do it would be where you add a new source you select the “add network location” option and in the server name enter only the machine name or ip address (“armani” in your case) and put the user/pass in the fields provided for them. Doing this will make a file in your userdata folder (passwords.xml) that contains the credentials instead of them being in the database. This allows for them to be easily edited if needed in the future just by editing that file, as well as making sure they are hidden in the logs. Additionally adding this network location makes it so the actual sources can be added just by browsing in Kodi instead of having to type the paths out. The credentials provided for the network path will automatically get used for all shares for that machine that had not been manually set to something else.

From your sources it looks like you used several.
Suggest on your Win 10 machine to open Command Line or Powershell and run net share and share the output here

To summarize:
I have created an account for kodi with a password.
I share the folders with advaced sharing and gave the user kodi full access
I kept IP addres the same and also the computer name is the same.
I also tried adding a connection in kodi using IP adress
I also tried adding a connection in kodi using IP adress :445, then I get a endless loop requesting Username + password ( to make sure
The last option was my note in what I found in a previus log that I made for the future.
I am sure I still missed something but not yet a clue what

BTW I also tried adding everyone with read acces with the same non working result

@fzinken What will the difference be?
I see the shares with the command, what else should there be?
Films F:
P P:
Users C:\Users
x P:\ERO

Compare to your Sources config

Other than P there is totally no fitting between your currently configured shares and your previous configured shares.

You where right, now I understand what you mean.
I did add those shares separate.
I removed all shares and added eacht of those shared folders on my F drive under the same name.
I tried adding te ero folder again the same way by adding a folder by the IP address/sharename.
Then adding credentials to get acces and also this works again.
I am not sure if i can disable SMB 1.0 again. I am to happy it works again, :crazy_face: :joy: :nerd_face:
I also update my own recipe to remember this better in the future and also added the link to this topic;) for futere reference