After October update original RF remote control is unpaired after reboot

After the last update from 2 days ago the original RF remote control is unpaired after each reboot of my Vero 4K+. The pairing procedure works, but it should survive a reboot.

I would consider this calling for a fix.

We haven’t had any reports of this issue.

What makes you think that the remote is unpaired?

Have you tried the remote dongle in the other USB port?

Have you tried changing the battery?

Can you confirm that you’ve tried an older version of OSMC and you don’t exhibit this problem?

We haven’t pushed any update for some time — certainly not two days ago and there has not been an October update yet.


First off: to me this response sounds a wee bit defensive. Maybe its only me, it is not what I would expect from the sellers or support end. So much for the non-topical feedback.

Back to the topic:

After the update I had an error message on screen during boot, it referred to lirc, but it was too fast going away. I checked the Kodi logs, but there was no such error.

I have the dongle in the “black” USB port (vs. the “white” port). For me it has always been in this port and always worked.

When I re-pair the RF remote it works fine until I reboot.
TBH it escapes me how this could be related to the battery. How would the battery know when I reboot the Vero to fail in exactly this moment, and then after re-pairing work fine again until the next reboot…

Details on the update: 2 days ago the OSMC on my vero downloaded some Debian updates I would think. If something got installed this was not displayed on screen. The Vero froze at some point then, I tried to navigate and to login via SSH, but to no avail.
I don’t know -what- was updated, but the OSMC version hasn’t changed, it still says September 2022 2022.09-1.

I am usually using BT to control the Vero and this still works across reboots. The original vero RF remote over here is in use only seldomly, still, it always “just worked” when I used it, up until now after reboots.

Thus, I am not inclined to installing an older version on the Vero.

The OS doesn’t have anything to do with the pairing of the remote and dongle. As far as its concerned there is just a keyboard and mouse plugged into that USB port that it takes input from. It doesn’t use lirc at all so whatever that message you saw was about would be unrelated. This makes a bit hard to understand how it could be occurring the way your suggesting. Maybe something went funny with your dongle that just happened to occur in the same time frame, who knows. As for the “wee bit defensive” I think your reading in a bit too much. Your saying that an update caused an issue that we have not previously heard of and are calling for a fix. Sam is just asking to narrow things down.

Well, that still leaves us without an explanation why the RF remote is not paired after a reboot. Not sure how “something funny” can happen to a dongle, so that it worked without problems until some update was downloaded, and then it unpairs on reboots.
That sounds more like a software topic to me than a hardware problem, but well, the people who know better can chime in.

Since you are the only report of an affected user, it’s highly unlikely to be related to the update.

I’ve not seen any reports of an issue from any other user. I’d like to get to the bottom of it urgently. This isn’t a defensive response but rather all of the questions needed to narrow the issue down. I’d rather ask for them outright rather than trickle down some questions.

If you can answer those questions, I am confident we can get the issue solved promptly.

If we’d had other reports of such an issue, we’d certainly acknowledge them and advise you accordingly. But we haven’t. OSMC doesn’t have any control over how the remote behaves as @darwindesign has stated. That’s why I’m certainly interested if an older version of OSMC reinstates the previous, functional behaviour.

Now that you mention you use the remote infrequently and use a BT remote, I have further questions. But I will wait until the other queries are answered as they may yield a solution.

Thanks for your understanding


I have been busy with non-technical things for quite some time. Now I am trying to come back to this issue, and things seem to have gotten worse.

(1) cannot even pair the BT remote any more
(2) a USB keyboard connected to any of the USB ports does not work
(3) my Harmony BT remote got disconnected

Luckily, CEC still works, so I can use the TV remote, also SSH and SMB still work to edit config files.

Via CEC I have been able to get (4) Harmony BT remote back to work. However, the Vero Original BT remote and the USB keyboard still don’t work.


It sounds like you’re experiencing an issue with the USB ports on the device themselves.

Can you:

  • Confirm which port you’re trying to connect the USB too?
  • Confirm that only keyboards / remote receivers are attached and no peripherals that would use a lot of power like hard drives?
  • Upload some logs via My OSMC with a keyboard or receiver attached


Ok, as originally written, I tried both ports to no avail. There are no other peripherals attached. As log files may contain private data I would need to know where these are going to be uploaded to and and which persons do have access to them. Which logs would you need? certainly not all?

The link contains info on sanitizing your logs if you are so inclined.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks although I was not asking HOW to upload the logs. My question was, WHICH logs are really needed, as it can be selected more fine grained. You propose to upload all logs, which my policy does not allow me to do.

Also I was asking what persons will have access to my logs. Without that information I have to assume that I may get publicly accessible or to a wide audience My policy prohibits uploading logs in such a situation.

Thanks for understanding.

If you sanitize your logs to your satisfaction, then it doesn’t matter if you post them to a utility pole in New York City.

Any number of these logs may/will hold pertinent info to solve your issue.

Do a search of this forum and I doubt you will find any report of any user who provably suffered any negative consequences of posting their logs by the method provided above.

If you cannot post useful diagnostic info for support personnel, I’m not sure what more can be done.


I’d like Kodi logs and system logs so I can see how things are interacting.
You can send me logs via PM, but as always, the fewer eyes, the more likely I might miss something.