After the update to 2020.03-1, OSMC will not play any files

After updating to 2020.03-1 version I will get the folllowing error:
ERROR: CVideoPlayer::OpenInputStream - error opening [/mnt/freenas_Movies/…

I tried mounting the network share in fstab and also using the KODI GUI.

The network share is hosted by FreeNAS-11.3-U2, and the Samba server version is 4.10.13 according to smbstatus.

I would like to point out a few things that I tried:

  1. I have a Kodi 18.6 client on an Nvidia Shield that connects to Freenas via Samba using version 3.0, and it can play any movies. The network shares are mounted only from Kodi GUI
  2. In OSMC I mounded the share via fstab using version 3.0, and receive the same error
  3. After mounting from OSMC (Kodi GUI) I get the same error
  4. The OSMC(Kodi) Samba version reported by Freenas, after I connect to the network share via the GUI is 3.11, hence I have tried with two versions:
    3.0 via fstab, and 3.11 via GUI.

The log is uploaded here:

You can search for “Anon.2018” - a movie, that I tried to play, for logging purposes, in order to find the error more easily.

The problem occurred only after the latest update, before the update I was using the same NAS and network infrastructure.

Any help is appreciated

Did you verify if the share is actually mounting? From a command line what do you get if you type:

ls -l /mnt/freenas_Movies

Sure, I can browse the contents, then I select Play, and nothing happens. When I looked at the log, I got:

ERROR: CVideoPlayer::OpenInputStream - error opening

Also I can get inside the directory, and browse all the contents with “cd” command via CLI

You didn’t answer my question, what happens if you run the command I gave? Not from Kodi from from SSH.

I have already used cd /mnt/freenas_Movies to check if I see any contents, browse, etc.

But to respond to the exact question, if I run ls -l /mnt/freenas_Movies, it will show all the files and directories I have on the share drive

I also uploaded the logs with grablogs, in order to be able to check for mounting errors, before I posted this

I’m suspecting a permissions issue, but since you don’t seem to want to do as I’m asking, it may be difficult to figure out. How about this, what do you get when you try (via SSH):

ls -l /mnt/freenas_Movies/Anon.2018.1080p.BluRay.DD5.1.x264-playHD/Anon.2018.1080p.BluRay.DD5.1.x264-playHD.mkv

I get this:

-rwxrwx--- 1 osmc osmc 8683354847 Feb 10 20:31 /mnt/freenas_Movies/Anon.2018.1080p.BluRay.DD5.1.x264-playHD/Anon.2018.1080p.BluRay.DD5.1.x264-playHD.mkv

And this is the line in fstab:

// /mnt/freenas_Movies cifs x-systemd.automount,noauto,rw,iocharset=utf8,vers=3.0,guest,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0