After unexpected update all PVR clients fail to load

Hi there,
My Vero4K said there’s an update available today, which I promptly installed but after rebooting my Simple IPTV client falis to load showing a message

“Add-on couldn’t be loaded. Can’t load shared library”.

The kodi.log file shows this
"UpdateAddons - failed to create add-on PVR IPTV Simple Client, status = 6".
No idea how to resolve this at the moment, any advice would be welcome. Also not sure what this update was about, don’t see any blog posts or tweets about an upcoming update so I do wonder about what that was all about.


The full logs might give some clues


Hey Sam,
thanks for the quick response.
Does this help [removed link by author]

Not really. Please see the Wiki for how to provide logs.

You could also try

sudo apt-get install —reinstall vero3-mediacenter-osmc

ok thanks. Can you give any insight as to what that update might have been about?

It removed the Also Allow Resolution Switch feature which caused some issues for people

@sam_nazarko I run the reinstall command and after two tries the problem seems resolved. I wonder though, if reinstalling worked, should I expect to see my osmc installation reset to a ‘clean’ state or is it normal to still see everything I had installed (addons, skins etc)?

No – it would only reinstall the Kodi binaries; and not change your settings.

perfect. thanks @sam_nazarko!


i am having the same PVR problem, “cant Load shared Library” when i try to enable pvr simple client.

i dont know how to write commands as i just bought this device and i know how to setup kodi, but not more.

Please help…


I’ve seen this a couple of times, a reboot normally clears. If not please start a new topic and provide logs.

Thanks Tom.

1 Like