After update, some .ts files stutter and are out of a/v sync

prior to the update, 1080p .ts files would play without a hiccup over the network and on the pi directly attached to the hard drive. now, it stutters and there is severe a/v sync problems. this problem occurs on both over the network (ethernet) and with the pi with the hard drive with the file directly attached.

Here is the log that has been edited slightly for privacy:

Here is the media info for one of the problematic files:

Any ideas? Thanks.
ps the trick to fix the double click on the remote worked great!

Glad to hear this.

Do you have the MPEG2 codec license?

Hi Sam. thanks for the quick reply. I do have the MPEG 2 license and it is enabled.
One more thing. It appears so far that every other type of file (blu ray and dvd - all saved as mkv files) work perfectly. of course i haven’t tested every file but these (.ts) are the only ones that seem to have this problem.

Try changing the deinterlacing method.

Thanks Sam. I changed to MMAL - Bob and that fixed it! Awesome!
I also changed it so that it was set to default.
Is there a way i can change it so that it will only be default for these type of files?

1 Like

You can set ‘Set as default for all videos’

that unfortunately sets it for all video files, not just the .ts files. any way to set it just for those files so that the others aren’t changed? thanks!

Kodi doesn’t offer this functionality unfortunately.

Maybe there is something we can do to improve this in a future update

I believe the higher quality deinterlacing methods weren’t used before.


thanks again Sam for your help on this. I think this is the quickest I’ve ever had a problem resolved by using a forum!

1 Like