After Update Videos don't play or yield black screen with Audio only?

Ok, this is a bit of a strange one.

I haven’t watched much TV at all the last 3-4 weeks and was out of town. Got home last night and decided to watch a movie. I saw that OSMC was saying there were updates available, but I declined the update. No problem watching the movie at all last night.

Today, I fired it back up and then applied the pending update and now I can’t play anything.

4K encodes don’t seem to play at all. The screen goes black for a moment like it’s playing the video and then it reverts to the Kodi home screen and I get the blue loading circles indefinitely.

I tried a 1080p encode and it did the same thing except I didn’t get the loading circles and it appeared to be playing as the audio was coming through? Hitting exit to swap between the player and the skin had no effect.

I’m using 8k 2.1 HDMI high quality cables and nothing has been moved or touched at all so I’m really struggling to see this being and HDMI issue. I haven’t torn apart the system and bypassed the AVR just yet because that’s a bit of mission and since it worked last night and doesn’t today after the updates, I’m thinking hoping someone can help with looking at the logs to see if it’s software/settings related?

KODI versions reports as:

2023-11-12 22:00:44.384 T:2758     info <general>: Starting Kodi (20.2). Platform: Linux ARM 32-bit (version for Vero)
2023-11-12 22:00:44.384 T:2758     info <general>: Using Release Kodi x32
2023-11-12 22:00:44.384 T:2758     info <general>: Kodi compiled 2023-10-17 by GCC 10.2.1 for Linux ARM 32-bit version 5.10.158 (330398)

OSMC version reports:

I’m guessing it is quite possible that it’s been awhile and the update I got lost night that seems to have broken things could well be the 2023-10-17 update. It might well have been several weeks since I used Kodi and did an update?

Log file above. First video that failed is Pigeon Tunnel. Other videos tested were Death Becomes Her and Defending Your Life.

There are no problems with network bandwith between KODI and my NFS mounted NAS library. I’ve thoroughly tested the Vero’s bandwidth via command line and it’s able to pull down data at ~180mbps.

I have an AppleTV setup as another device and running Plex and no problem streaming and playing the same content and movies over Plex. Of course, I prefer Kodi, and really only use Plex when I’m not home or if my Vero/OSMC/Kodi is having problems.

You have stumbled on a development build that didn’t work. You can reinstall or hope Sam pushes later patches to the staging repo that fix the problem.

Then you need to remove bullseye-devel from apt sources to avoid surprises.

@grahamh woah…how the heck did I get development builds listed?

So, at least for now, I should just delete the bolded line below from /etc/apt/sources.list ?

deb Index of /debian bullseye-updates main contrib non-free
deb bullseye-security main contrib non-free
deb bullseye main
deb bullseye-devel main

Or should I wait and see if @sam_nazarko chimes in before I do that?

Also, does the rest of my sources.list look ok?

Reinstalling is a bit of mission if I recall correctly with using an SD card and I’ll have to reconfigure from scratch I suppose?

You can delete that line but it won’t revert the updates you’ve installed. It would be better to keep the staging repository for now as I plan to push a fix shortly.


1 Like

I’ve pushed a fix for this now and it should be available shortly.

Please keep in mind that we’re still doing work on deinterlacing however, and you may still have some issues with deinterlaced clips.

But HEVC playback will now be fixed on the whole



Fix received and back up and running - thanks for all your hardwork @sam_nazarko

Thanks for confirming and sorry for the inconvenience.


1 Like

Should I strike that from my sources.list? Or would it be best to keep it there? I think this is the first time anything has broken for me in a long long time so happy to leave things as-is

If your okay with the risk that you might have to wipe and start over then it is up to you. Obviously the least risky move would be to remove the development branch. When you see one of the mods or devs post for someone to try something that is in testing it is always at a point where they know testing is usable. The thing is, sometimes testing breaks stuff and there is no public resource to let people know when a test build update is risky or not.

FYI - I had a similar experience when letting OSMC apply the upgrade through the UI.

Looking at the logs, I saw that Kodi upgrader could not upgrade one table so the DB migration to 121 failed (from 119). Was a strange error. sorry, no more details, I cleaned it out.
What I did was:

  1. stop media player
  2. delete in the DB MyVideos121
  3. Start media player

And while starting the media player again, I watched the logs.
This time the DB migration went through though, without an issue and I could watch/play back videos again.
I really did nothing else.