After updating to new versions my Vero 4K lost connection with my local SMB network

Unfortunately for me I suddenly fell into the trap of updating my Vero 4K Osmc and found out that none of my local SMB network media file is available any longer. I tryed everything but no success. Once I fall back to Kodi 19.X version everything works fine. Can any of you could help me, how to solve this?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

I have uploaded my logs, ozoxehepur

Does it start working if you stop forcing SMB v1?

I have tried all possible settings, none helped; the only way to use my Vero 4K+ if I go back to 2023-1. Problem is that 2023-1 does have video sound issues with my devices and now I can not go back to earlier versions where that sound issue have not existed. The legacy SMB problem came with the 2023-2 and remained in 2023-3 for no one reported it.

And you restarted Kodi after changing min/max SMB version? I would add another source using the ip address of your server to see if that works.

Yes I restarted just like as it was equired by the GUI. Sometimes it got stuck and did nothing so I had to pull out the power cord to get it back to work. It took me one and a half hour to try all possible settings, none helped. Thus I just went back to 2023-1, so that at least I could use my SMB shares without any issue. I am pretty bad at using network shares so I was happy that I could set up a way to get it work.
Too bad I forgot, once I upgrade from 2021-something version, HD audio sound issues will emerge immediately. And right now there is no way for me to go back since that version is no longer available.

Sure there is…

The OSMC installer has an option for selecting images you had already downloaded.

Although personally I think you would be better off just searching through this forum and learning how to properly setup your Windows file shares (I assume that is what your using based on share names) and add them to Kodi. There is at least one howto and I know I have outlined in more than one post where I walked someone through in great detail. I can’t think of any reason for the issue your having other than name resolving issue due to using “workgroup” as the network location your pointing to.

Thank you very much for the link to the older versions and also for the advice on how to use winshares properly. I will give it a try pretty soon. Mind you and just off the record: I have not changed anything in my winshares yet once upgrading from 2023-1 to 2023-3 my workgroup ceased to be available as a SMB drive. I downgrade to 2023-1 and the share works like a charm …

I understand that, but the trend towards removing or just not continuing support for ancient file sharing standards is not going to reverse. Here is a couple links to get you started…

Once again thank you for your time helping me on this, I’ll definitely go through the procedure once I’ll steal some time to do it.

Eventually I went down to 2022-11-01 (Kodi 19.4) and everything worked like a charm except two little problems, but fortunately each having quite good workarounds. But people are curious creatures so I tried to upgrade to 2023-3 to see if it cures those problems.

I managed to solve the SMB v1.0 issue subject to this topic taking your advice, recording the windows computer itself as a SMB share instead of using the WORKGROUP method and it worked like a charm, found all my network drives from that computer available even after upgrading to 2023-3. So I checked whether those two minor problems are handled any better at OSMC 2023-3.

  1. Switching between HD audio tracks during playback of a video still requires complicated workaround, but manageble at least.
  2. To play an mka music file, however, that has a DTS-HD 5.1 and a FLAC 2.0 track for each song is now impossible to do no matter what audio settings you use or what trick you try. This type of playback was not an easy one even at 2022-11-01 but it worked sometimes, now it is gone. Odd enough if you play an mka music file that has a DTS 5.1 and a FLAC 2.0 track for the songs everything is allright, no problem with the playback at all.
1 Like

I was a bit curious so I gave it a go and made it work with a bit of a hacky workaround. Obviously this type of file is not some standard so to make my file I ran a copy of 2001 with DTS-MA through handbrake and had it spit out just chapter two that the DTS-MA track untouched along with that same track converted to stereo flac. I then put that file into mkvtoolnix gui and dumped everything but the two audio tracks to have it spit out a dual track mka. The result was Kodi would play the file but would crash at the end of playback. Didn’t matter if I used videoplayer or paplayer, same result. I can’t be bothered figuring out why the crash but I would note that with playing an audio only file Kodi had no method to select which track was played and which actually played was whichever was set to ID 0. Which track was set as the default audio track wasn’t respected. Next I fed the video handbrake originally spit out back into handbrake and had it save out ten seconds and then put that into mkvtoolnix and dumped everything other than the video track. Once I had this I could just keep on copying this mkv and renaming it to match the file name of every mka I made. Played the mkv files in Kodi and it played the audio perfectly and I could even select which audio track was being used. Note that once your using the external audio track method to play the files which audio track is being played is now whichever is set to default. I then cued up a few files into a playlist and they rolled right along just like playing an album.

First of all, OSMC build 2022-11-01 is able to play that type of files, the only problem is that at the end of playing back the first track, it’s “got confused” and stop playing the rest of the tracks.

At second, Kodi under windows can play this type of files without any trouble, no matter whichever Kodi version we talk about, it has been working to me since 2017. You may even jump between the tracks, no problem at all. (Mind you I have already reported this issue a couple of times, and once again I’d like to remind you that the problem exsists only with DTS-HD track, simple DTS works flawlessly).

Thus I think it is not a Kodi issue, it is definitely an OSMC problem. In my view it has something to do with activating and deactivating the audio passthrough output. If I am right, that would explain the other issue, when switching between HD soundtracks during the playback of a movie.

If the root cause of the issue is the SMB protocol version …

The samba project changed their default SMB level of protocol used to improve security and performance. Dropping a 20+ yr old version of the SMB protocol was part of that. Win10/11 forced this change as they are on smb v3 and v3.1. Win7 was on SMB v2.1 as a reference point.

Additionally, MSFT changed the discovery from using nmb to mDNS/Avahi. This means that browsing to shares has changed. For most people, it is easier to just use the IP address to the storage server.

So, the “best” solution is to replace any devices using SMB v1 that can’t be toggled to SMB v3+. Effectively, all versions prior to v3 are deprecated and shouldn’t be used anywhere.

Of course, many of us need time to save and purchase a NAS that supports newer standards.
There may be another option. If your NAS supports NFS, enable that a NFS v4 levels. NFS streaming performance seems to work better with Kodi/OSMC. I don’t know why, but it does. If you are using MS-Windows to perform the sharing, I wouldn’t suggest using NFS. That’s just a world of pain. However, for any Linux or BSD (including MacOS), NFS is native and works well. It is very stable and sorta “just works”, provided you setup the file permissions correctly.

Hopefully, this isn’t 100% off-topic.