After yesterday's update: hevc is broken

after yesterday’s update my vero4k+ is no longer capable of displaying hevc content.
UHD TV channels show a pinkish picture with small vertical stripes, 1080p content displays the first frame and 720p content displays a few frames and that’s it. Sound, though, in all formats works fine.

Is there a possibility I can go back one step, a how-to maybe?

Kind regards


Please post some logs so we can see what version your device is on.

Just done: qeliruluqa

Your logs show that you are running experimental test builds that are not recommended for production use.

The issue has since been solved however, and checking for updates again and installing them should resolve the problem.

Unfortunately, there are no updates to install. Just did “update” and “dist-upgrade” on the command line.
I guess the issue is rooted in “deb videoimprovevero49 main” in sources.list, isn’t it.
Would it help to remove that line and try another update?


Editing the sources.list will not remove the test build. If you wanted to stop using them you would have to do a clean install. That being said this kind of issue is the point of testing in the first place so bugs are found before general release. This should have been posted in the testing thread which is also the place where you will find if any particular issue is known or not.

Thanks for the advice. This is kind of unfortunate. I did not even remember using the test builds. Will reinstall from scratch using the backup created by osmc as well as the database backup.

Maybe the moderator can move this thread to “Testing”.

Thanks again.

One can only switch to this test build by manually editing the sources file via SSH so this would have to been something you chose to do at some point (perhaps to get 3D playback). Please note that the backup in My OSMC is only Kodi setting and not the OS so you will have to use the installer to renew your system to stock and only after that restore your backup to get your Kodi userdata back.

At this point I will just mark the thread as solved and leave it here as it would provide no benefit in the other thread.

Yes, I am aware of that.

Thanks again.