Airplay not working - was INTERMITTENT,

First I wrote:
Have just received Vero. Airplay from iOS 8 is not working.

I can select the Vero/OSMC but when I try playing audio from more than one phone app it disconnects.

Sometimes a delay before I can select it again.

Playing fine to my raspbmc.

Have toggled the iOS 8 switch with no change to behaviour.

Have also updated OSMC to Apr 12 build.

But now:
Is working fine, as well as mirroring.

Not sure what was wrong…

a month or so later

Still lot’s of problems with Airplay from iPhone

Just updated OSMC on the Vero to Kodi 14.2 20 April.

That seemed to help a bit, sometimes.


  • can’t connect from iTunes v12.1.2.27 - says “The AirPlay device “Vero” is not compatible with this version of iTunes.”

  • my old raspbmc on a pi still seems fine

  • the raspmbc has icon like a screen; the kodi has one like an iPod

  • for a little while on my iPhone the Vero had two icons - the iPod one and the screen. The one with screen worked, not the other.

Has anyone else had similar problems with AirPlay?



so a reboot of Vero (yes I’ve tried many) has led to the screen icon for the OSMC coming back.

you could say it’s working


for the moment

Make sure you don’t try to enable the mirroring toggle on your iOS device or it will disappear from the Airplay list altogether and can be difficult to get back. Kodi doesn’t support mirroring but has to advertise that it does otherwise iOS 8 will not send any video to it at all. (Even non-mirrored video)

Generally if Kodi Airplay targets stop appearing it’s either the above, or you need to toggle wifi off then on on your iOS device or occasionally a full reboot of the device is needed.


Yes, the mirroring switch has gone from iPhone.

But is mirroring photos now too.

Today neither iTunes on computer or iPhone can connect to the Vero.

It’s changed back to the iPod type icon.

Have rebooted all devices.

Anything else I could try?

Have tried multiple iOS devices back to iOS 6.

Devices can’t find the Vero OSMC at all now.

Try rebooting your router.

Hi, Im going to just throw this out there, as I am having same issue.
Airplay starts working fine, and then after some random period of time it stops working.

On hearsay I am presuming there are people out there without airplay issue?
Which would appear to indicate the problem is in some other indifference.
So lets see if we can figure out what the root cause is?

Here are my parameters.

  • Hardware = RasPi-2
  • Using Ethernet and static IP address
  • OSMC latest update, kodi 15.2.
  • IPad2 version 8.0.2 with static IP address
  • Router Service Provide supplied Huawei HG533 firmware v1.20t

First of all, I confirm the router has a fault with dhcp daemon I have complained to the service provider about this, hence why i have set all devices to static IP.
So I don’t care if they fix dhcp issue or not, but I am starting to wonder if there is another networking fault with the supplied router.

I did disable the firewall, incase it was filtering Bonjour broadcasts, but not got any further on my diagnosis yet, but if other people do not have issues then it has to be something I have in common with the people who are having the issue. Anyone care to figure it out with me?
I don’t want to invest too much time on it if it turns out to be a software/code issue, but at the moment there are some hints to suggest its the apple device or network related. However, a reboot of OSMC will permit the connection to work again for a short while, so is the issue really with airplay service?

Just an update.

I’m still testing this out but unbelievably changed Auto Lock setting from 15 to never
Ipad > General > Settings > Auto-Lock > Never

So far Airplay been fine for over 30minutes

I thought when iPad was connected to the charging supply the auto lock didn’t kick in? and that seem to hold true as never had to unlock the screen, but seems the auto lock feature interrupts airplay working, and then Kodi doesn’t seem to re-establish the session
Would be a good feature to be able to restart the airplay service

The problem is iOS 9 breaks Airplay support in Kodi, bigtime. (No audio or video)

And the changes made by Apple this time seem quite substantial. So unless the Kodi devs are able to reverse engineer the iOS 9 changes to make Airplay work again, I doubt they will expend any energy trying to solve remaining bugs in Airplay support with iOS 8 devices if Airplay will no longer work with newer versions of iOS.

Airplay support in Kodi is based on reverse engineering old versions of the Airplay protocol and has always been a bit flaky as nobody (except Apple) really knows how Airplay works and there is no public documentation available for 3rd parties to implement it.

There’s no Airplay service - it’s an integral part of the Kodi binary. If toggling Airplay off then on again in the settings doesn’t help then your only option is to quit and restart Kodi.

Many Thanks DBMandrake
I already kinda knew this, but really appreciate the confirmation and explanation.
Well the good news is turning off auto-lock of the sending client device seems to have done the trick.

OK so just an update, changing this setting did seem to improve the symptom a little bit and airplay did work for a good 40 minutes.

However, the symptom remains.

I have done some reading on Apple forums and discovered that the symptom does not seem to be limited to airplay on kodi and actually seems to be quite a common complaint with apple-tv, macs and airplay in general even between apple client devices. The more i have looked into this, the more Im starting to think it’s a multicast issue with the router. I haven’t solved it yet, but I’m working on it. :smile:

Noone out there seems to have figured it out, only made half-way workarounds that reduce the symptom occurring.

Ok so I have finally cracked it

This might prove useful for many people.
On further reading and analysis, I have discovered there seems to be a large number of routers out there with buggy firmware. On reading about the so say benefits of reducing multicast traffic with IGMPv3 it would appear that Huawei, d-link and netgear products are known to suffer from the symptom.

I resolved this by disabling IGMPv3 (router default) and down leveled the router to use IGMPv2 instead. Also disabled IGMP snooping and IGMP proxy on my router. For info IGMPv3 is supposed to improve multi-casting by forwarding multicast to a specific device address thus reducing multicast traffic.
For a home network your unlikely to have hundreds of client devices contributing to multicast storms, and as ISP/providers don’t seem to be able to fix these known firmware issues with IGMPv3 you don’t really need it anyway.

Hope this proves useful out there. Been streaming for over 2 hours with no halting issue & no need to reboot kodi to restart the media service. I still however if I am critical notice 1/100th of a stutter occasionally but again that’s probably another bug with the router.

Nice troubleshooting!

Yes bonjour is a multicast protocol and as you say some “smarter” routers will try to minimise multicast traffic for various types of multicast traffic such as using IGMP snooping, Bonjour proxies etc… for example our enterprise wireless network at work has “Bonjour service control” which does a similar thing to what your router was doing and it can cause issues if not configured properly.

In a small home network as you rightly say none of this is needed, so it’s best to turn off any features that might be intercepting or filtering multicast traffic and just allow all multicast traffic through.

1 Like