All TV shows have disappeared

All of a sudden, all the TV shows have disappeared from my Vero 4k. The files, on a NAS, are still there. Movies still work fine, as does watching live TV.

I’m using the Arctic Zephyr skin, but even using the default OSMC skin has the same result. I have also rebooted as well as powered down and then up the Vero, the NAS and all network equipment.

In Zephyr, if I go to Settings → Library → Library → Videos → Television, I am able to browse the NAS and play a TV show’s video file.

However, if on the main screen, I go to TV Shows, I can see all the shows listed, but going into an individual show there is nothing there, no season posters, nor episodes and it just says “No information available” and the only thing to select is a back arrow.

If I am at the screen where I can see all the show posters (Main screen → Tv Shows) and I choose on the remote the 3 horizontal lines (above stop button) , then information, then manage, then refresh, I get the option of Yes/No to refresh TV Show information. I choose Yes. Next is another Yes/No option to refresh info from internet or use local info.

If I choose No, it does something and at the end of says “No information found” and some, but not all seasons appear.

If I choose Yes (refresh off the internet) the show is back. Unfortunately, which episodes that have been viewed is now gone. It takes several minutes to refresh even a show with few episodes. A show with 60 or so episodes will take a good 10 minutes to process, even with fast internet access.

What might have happened and how can I have this refresh done en masse?

Debug enabled logs might give some ideas what is going on.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:


I have followed your instructions and the log is available here:

I tried to recreate the issue by going into a TV Show, Chernobyl, and there is nothing listed. I then went through the process I described in my original post. The first few times I tried, it said it was not possible while scanning for media information. I believe this is the automatic scan that happens upon startup which, incidentally, doesn’t not find or update any of these problematic tv shows, although it used to.

The log may also show some shows (Veep for example) as being fully “there”. This is one of the shows I manually refreshed much like I just did for Chernobyl

Did you happen to change what scraper your using right before this happened? Also maybe you have items that were set with a scraper that is not currently enabled/installed. Regardless you may be better off, since you have already lost your watched status anyway, to just dump your library and scrap into a new fresh library. This would probably be faster, easier, and less prone to errors that trying to clean up what you have now.

I certainly didn’t change anything with the scraper, but perhaps there was an automatic update that screwed it up. I think you’re right though, going show by show and rescanning each one is a pain.

If you didn’t change the scraper and choose the option to rescrape, and you didn’t manually tell it to clean the library when the network was down and also choose the option to bypass the warning that likely would have come up, then I don’t think your likely to find any answer to what happened other than to just assume there was some kind of corruption in the database. Normally when people have run across this in the past it was because they had the option set to clean on update. You don’t have that option set and Kodi deals with this better than it used to.

This is all assuming the items really are gone and not just being hidden by the watched filter in the slideout menu.