All USB attached hard drives gone *solved-usb hub failure*

I recently upgraded to Windows 10 and while I was no longer able to access the drives via the network, I was able to use WINSCP to FTP into them.
That was about 2 weeks ago.
As of this morning, all drives are gone when I FTP into the Vero 4k
There is a message inside the media folder where all my drives would show stating:

#### Notice ####
This directory is for automounted drives. Empty directories here are purged on reboot.
If you wish to configure an /etc/fstab mount for a drive that is attached permanently, you should do so in the /mnt directory

Drives were shared via smb.

I went into System and SMB and it was set to Max version SMB3, since I saw some posts earlier, I saw setting it to 1 may help for a temp fix, to no avail.
None of the drives show mounted via Video–>Files

Drives, usb hub, and Vero hsve been rebooted multiple times.


What is the output of


run on the Vero?

Is there a specific dir I should run it from?
Right now says:

/home/osmc$ lsusb
-bash: line 12: lsusb: command not found

Sorry, I forgot it’s not installed by default.

sudo apt install usbutils

After that completes you can then run lsusb.

sigh I promise, I’m reasonably tech savvy, but this still doesn’t work.
And after I ran that script, I rebooted as well, still says command not found.
Uncertain if related, but now every dir I access via WinSCP says “Invalid access to memory.”
Still allows me in though.
Not a good morning thus far :slight_smile:

What happened when you ran the apt command?

Well lsusb would be helpful. But otherwise as a first think run grab-logs -A and provide the URL

Thanks, will do that also.
I installed putty instead of using the telnet window in WINSCP, that seems to have been the issue.

/$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 008: ID 2017:1688
Bus 001 Device 006: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 001 Device 002: ID 0b95:1790 ASIX Electronics Corp. AX88179 Gigabit Ethernet
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

It seems to see your hub, but not the attached drives. Maybe your hub has failed. Try connecting one of the drives directly to the Vero as a test.

Was thinking that too…
Logs available at
I suspect they will just show that no media is found…

it shows

  • one port of the Vero has an Amazon USB-Gigaethernet adapter or simliar installed
  • on the other port of the Vero there is a 4-port USB hub connected which sees a Logitech wrieless receiver and keyboard/mouse device (the OSMC RF dongle)

So it does appear that the USB hub just died.
I picked up a TP-LINK USB 3.0 7-Port Hub UH700 and they now appear.
I have to do some more testing though as after I plugged it in, and rebooted the Vero it went in a Please Stand By loop.
I unplugged the hub and rebooted again, the vero is back, and I reconnected the USB hub. The drives auto mounted as expected.
But why would that loop happen?

The hub is powered, although not a 12v, but my enclosures and external drives are all powered anyways.
4K Sony XBR75900E, Denon 2300w receiver.

Very odd behavior, not sure what happened but today has not been a good day tech day. Glad it’s back, but am not optimistic about my next shutdown and power up…

Do you have a Seagate drive?

I do, an 8TB powered external and a few of the internals are Seagates as well.
As of last night and a few reboots, seemed to be back to normal.

This stand by issue has occurred again after a lockup. You asked about seagates why was that?

Some Seagate drives have a firmware issue