All Videos are very dark compared to DS Video


Like the title gives away, all videos are very dark on the very. It bothers me for a some time now and always thought it was the TV. So I went into the service menu and forced the TV to always have max background lightning, but the content was still dark. As soon there is some sort of shadow, almost every shadow gets deep black.

The TV is a Samsung QE65Q70R.

To see if I bought a complete s*it TV, I played the same content on DS Video and there it’s fine! I tried to take pictures, but its hard to get a realistic representation.

DS Video, all details are visible. only the real black parts are black.

Vero, almost everything is black. the camera tried to brighten it up. In some shots you can barely see the faces.

What settings could I make to get rid of this darkness?

Here are my logs:

Help is much appreciated.
Cheers, Stefan

What type of files are you playing? Are they HDR?


Any kind, but usually non HDR. This example is no HDR. At least I don’t think it is. Can I check the file somehow? Just downloaded.

What is Ds video?

Its an app from synology to stream videos from your synology NAS to your TV. And the App is installed on the TV, just like any other

1 Like

So, you have two different inputs:

  1. Vero 4K+ via HDMI to TV
  2. DS Video app to TV

Most TVs have different settings for different inputs. In your case, you need to make sure the internal or app “input” has the same settings as the HDMI port that the Vero connects to. In addition, you need to make sure the DS Video app doesn’t have any settings that might be changing the picture.

Looking at your screenshots, my guess is the “correct” settings are somewhere between the two pictures you posted. The DS Video has the black level too high, while the Vero seems to have contrast or saturation set incorrectly.

If the files are HDR, could be because Vero still doesn’t pass MaxCLL / MaxFALL HDR metadata, if don’t check the picture settings, it could have different settings depending of the image input.

The DS Video app has 1 Video setting point. Subtitle size… :smiley:

And for the TV, the Image settings are set to “All Sources”, so if I change something, it will do it for everything. If I increase the sharpness, it will do it for the Vero AND DS Video :-/.

The most correct would probably be the DS Video. The camera tried to “fix” the picture and altered the black levels. I can’t get it life like. Otherwise, the Vero picture would be much darker :smiley:

On my TV, to configure video settings for built-in apps (like Netflix, etc.), I need to start the app, start a video playing, then select the TV menu that allows me to change things like contrast. Every modern TV I have seen can store settings for each input separately, and this should always be enabled, to avoid processing that can hurt picture quality.

Also, really dark video can be a sign of a mismatched pixel range (TV/PC). I can’t imagine that the setting for that would be global, as it only applies to HDMI, and often needs to be different for different inputs (e.g., if you have a PC hooked up via HDMI).

Throwing in a wild guess about unconfigured HDMI deep colour on one of the HDMI inputs.

1 Like

Yes, that’s correct with my tv aswell. BUT, I can choose if I want to apply the settings for the current application/Input or for everything, all external and internal sources. HDMI and apps. And right now its on “All”. I will try it with a usb stick tonight and see if the video is dark too.

Settings>System>Display>Use limited color range (16-265)> [Enable]


THANK YOU SOOO MUCH! This did the trick! Again, thanks man!