Allo Digione


I need help to get OSMC working with Allo Digione. I did find an overlay for it here: firmware/boot/overlays at master · raspberrypi/firmware · GitHub but I don’t get it to work. Hopefully someone already solved this and can guide me in the right direction.

Many thanks!
/ Simon

Perhaps @popcornmix can advise.

What doesn’t work?
Did you select it after activating it and rebooting it? Does it appear as an option?

Contacting Allo is probably best bet. They have PR’d changes to My OSMC for their DACs in the past.

Thanks for the quick replies!

I understand that I should have been more specific to start with. It does not appear as an option and after manually adding the file to the overlay direction and configuring the config.txt it still doesn’t appear.

I will contact Allo as well. Thank you!

Allo got back to me:

“Please check with OS , maybe they did not integrate the drivers ? Our drivers for DigiOne were already submitted and accepted in Rasbian”

So I’m still a bit stuck… :expressionless:

I have now tried Allo Digione on DietPi with Kodi and Digione works good but I really do prefer OSMC. I have added the .dtbo file to overlays and changed the config.txt. What do I have to do more to get it to work??

I can’t see the card if I type aplay -l btw so I must be doing something wrong with the overlays. Can someone please send a link to some similar problems because I’ve been looking but I don’t find any good info on how to proceed…

Many thanks!
/ Simon

Hello all. I wanted to follow up on this post as I have a Digione on my pi and am trying to configure it to osmc. I too believe I have loaded the overlay and configured it but I do not see it as an option in any setting on the osmc software. I am hoping someone has an answer or will be willing to help. Thank you!

Should be supported in the next kernel update

Hi !! I have the same problem with Digione audio output and OSMC…
Do you have a prediction about the update release?

There is already a test thread for Kernel 4.14 you can try it already

I test kernel 4.14 with ALLO DIGIONE on PI3 and it’s OK.

thanks for support. HELLO

Could you share the details for how you got them working together?

I’ve added dtoverlay=allo-digione to /boot/config.txt, but that doesn’t seem to do the trick. Anything else one needs to do?

Update: Seems like one needs to activate the dtoverlay inside the OSMC app as well before anything happens.