Allow passthrough doesn't work

Hello everyone!

Couple days ago, the Allow passthrough option stopped working for me.

OSMC runs on raspberry pi 3 with a 2TB USB HDD for storage.
The rpi is connected through HDMI cable to HDMI audio splitter which is connected through HDMI cable to my Sharp Aquos TV and through coax cable to my 5.1 surround system.
So, rpi3 (HDMI) -> HDMI audio splitter (HDMI) -> TV
(coax) -> 5.1 surround system.

So far, I’ve been able to get 5.1 surround sound by using above setup and Allow passthrough option.
I really have no clue what happened, but it simply doesn’t work anymore.
There is no sound what so ever on the 5.1 surround system, only on my TV.
I’ve rebooted all devices and checked the cables. I’ve also tried reseting my audio settings to default and setting Allow passthrough again.

Here is the MediaInfo output and here are the full set of logs.
The actions that I took after enabling logging and rebooting is to simply navigate to the media file and play it.

If anyone has any idea what might be the problem, I would appreciate it.

AFAICT, your Pi is correctly sending AC-3 (Dolby) sound to the splitter. If it’s reaching the TV, I think it must be PCM. Does the splitter convert it? Can you post the model number?

Can you screenshot and post your audio settings, please.

As @grahamh requested, the screenshots of all settings in

Settings -> System -> Audio

should help to understand your situation.

A classic problem is to have

Settings-> Player -> Video -> “Sync playback to display”

enabled since this prevents passthrough usage.

@grahamh, @JimKnopf

The splitter is a budget no name one I got from AliExpress. I have the specs in the manual if more details are needed.

Here are the screenshots of Settings->System->Audio and System->Settings->Player:



Let me know if I can provide more details that can help resolve this.

You need to enable the “AC3 transcoding” which is inactive in the second screenshot.
Let us know how this is working.

@JimKnopf, I’ve tried it but it didn’t help.

I’ve played a little bit with the setup and concluded that something happened to the splitter.

The main reason why I bought it in the first place was because I believed that my TV cannot send 5.1 signal to the speakers. At least that’s what it stated in the manual - the coax audio out is 2.0.
I never tried Allow passthrough option because of this until now.
And guess what. It works.
I actually didn’t needed the splitter at all :slight_smile:

To summarize, the setup that works now is rpi3 (HDMI) → TV (coax) → 5.1 surround system with only Allow passthrough option enabled.

Thank you and @grahamh for helping me!

I’m not sure how to close the topic, since I consider it resolved.

Ok, excellent. But the Sono only understands 2.0 PCM and AC3 from the Vero. Most possible you have tried playing AC3/Dolby Digital material for which the passthrough setting is absolute correct. But a DTS core or any other format will get you 2.0 PCM … but you can improve it by letting the Pi make a multichannel AC3 out of it which should be forward to the Sono. So, give the additional setting “AC3 transcoding” a try.

This is what I used to test if the sound output is 5.1 or 2.0, so
I guess you are right and enabling the AC3 transcoding can only help if the source is not AC3/Dolby Digital.

Wouldn’t it then make sense to enable the rest of the options like Dolby Digital Plus and DTS capable receiver?

Not if your TV does not support passthrough of these formats, which most don’t.

I’ll definitely check what does my TV support, but if I leave only AC3 and AC3 transcoding options enabled, that means that that only AC3 source will get to the TV untouched and anything else will get transcoded to AC3?

PCM 2.0 and AC3 untouched, the rest will be transcoded to multichannel AC3.
The Sono playbar does not understand any other format like DTS, DTS-HD, TrueHD, etc.

Sorry, mixed this with another topic where a Sono playbar was used. You’ve to check with your TV and surround system, what can be forwarded by the TV (passthrough) and decoded by the AVR.
Trial and error is also a way to get this information. Test trailers you can find here: https://thedigitaltheater.com/index.php/category/audio-format-trailers/

I’ve checked the TV manual and it says:

Digital audio output setting
After connecting an amplifier with RCA digital audio input as shown, you should set an audio output format compatible with the programme you are watching or the device connected.
Press MENU and go to Setup → Sound → SPDIF mode → select PCM or Dolby Digital.
NOTE
When you set this to Dolby Digital, and you receive the Dolby Digital or Dolby Digital Plus audio formats, Dolby Digital audio is output. Otherwise, PCM audio is output.
When you set this to PCM, PCM audio is output no matter what audio formats you receive.

It looks like I can enable Dolby Digital Plus (E-AC3) capable receiver option also.

5.1 surround system can handle AC3 and DTS, so it’s a pity the TV cannot output DTS.

@JimKnopf Thanks for the test trailers!