Alsa doesn't work after last update

#1

Hello,
yesterday i updated my osmc on Raspberry Pi 2 and after update mpd, which i use to play audio when tv is, off stop working.
It looks that problem is with alsa, because alsa cant see any sound card.

If i run alsamixer

root@osmc:/home/osmc# which alsamixer
/usr/bin/alsamixer
root@osmc:/home/osmc# /usr/bin/alsamixer
cannot open mixer: No such file or directory

if i run aplay -l

root@osmc:/home/osmc# aplay -l
aplay: device_list:268: no soundcards found…

Could you please help, how to fix it?

#2

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

#3

Try adding dtparam=audio=on to /boot/config.txt

8 Likes
Squeezelite finding no audio devices after upgrade
#4

Thank you very much fzinken, you suggestion solve my problem.

#5

Just came here to say thank you to fzinken!

I had the same problem after the update with MDP!
And your solution helped me.

You`re the best!

#6

Hi all,
as Da_FluX, just here to thanks fzinken, and osmc in fact for the greatl work!
But, just to understand, we need to activate audio on boot, therefore it seems not to be a problem for OSMC… Can you explain?

#7

Not 100% sure what you mean with your comment. For the time being you once have to add dtparam=audio=on to /boot/config.txt. This will then be applied after a restart and for the future.
If you don’t want to that just wait for the december update where it will be added to OSMC automatically.

1 Like
#8

Thank you very much fzinken, you suggestion solve my problem too.

#9

THANK YOU! This has been bugging me for a week!

#10

Thank you very much, I’ve struggle for it for about one week. It really works.

#11

This worked for me, too! Much appreciated – I spent HOURS trying to fix audio on my R-PI 2!

#12

I just wanted to add my thanks to fzinken as well… Adding dtparam=audio=on to /boot/config.txt fixed this problem for me.

I’m going to just add in the error messages I received, to help anyone else who might be googling for this solution. Here’s what my Raspberry Pi was reporting:

ALSA lib confmisc.c:768:(parse_card) cannot find card ‘0’
ALSA lib conf.c:4241:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4241:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:4241:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:4720:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM default

#13

Thank you so much fzinken for you help!!! Been having this issue since i updated my pi and your fix worked!

#14

Just made an account here just to say thanks! This was my fix after few hours of research.
It should be higher in the google results :slight_smile:

#15

Thank you! fzinken. It has been down for 2 weeks.

#16

Thanks fzinken! This has been driving me batty all morning, and my usual trouble-shooting failed. x86 has me spoiled.

If your soundcard isn’t detected, but you’ve already confirmed that you’ve loaded the snd_bcm2835 module, this is probably your solution.

#17

I created an acc here just to thank you fzinken! It helped me too!

1 Like
#18

2 years and 14k views on this later, I’m commenter 17 to say THANKS and thats the only reason I made the account here!!! Stupid me removed this line with some others and couldn’t for the life of me figure out why it wouldn’t work! Great Job Fzinken!!!

1 Like
#19

I thought I had this enabled by default, but don’t remember off the top of my head now.