Amazon Prime not playing video after April update

#1

I updated my Pi3 to the Kodi 18.2 RC today via the My OSMC updater.

I had previously attempted various ways to get the Amazon VOD app to work on my device when I was still running Kodi 17. Maybe that was a mistake? (I’m getting this from the Sandmann 1.02 repo)

I tried several methods today of getting the app to work. It doesn’t work any differently than it did under Kodi 17, as far as I can tell. I reset all the settings in the Amazon VOD app to default. Signed in under my account, etc.

What happens now is that I can load my watchlist with all my favorite items, but when I attempt to select a video to play it either notifies me of an HTTP error, or just never loads anything.

I’m confused. I thought this was supposed to be supported natively in Kodi 18 somehow. All the instructions I find still refer to third party apps like the Sandmann repo Amazon VOD app. Did anything actually change?

1 Like
#2

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

#3

I’m thinking libwidvine missing perhaps?, since i never used the add-on I don’t know if it uses input.stream.helper, to download and install libwidvine, which is used by most DRM-services like Netflix, Viaplay and my guess Amazon too.

You might wanna update the add-on zip, since there were changes 16 days ago.

#4

Sure, I’ll try to get some logs posted up tonight. I was able to figure out the debug mode the other day, so I’ll try that later when I’m home again.

Yes, I believe the Amazon addon also uses widevine. IIRC, I think my system ran through the install for that back when I was on Kodi 17… although of course it didn’t really work right then. I was not prompted to install it when I tried to get the Amazon plugin working post-install of Leia.

Did you mean updating the Sandmann addon zip? That has the same version number as it’s had forever, as far as I can tell.

If someone could point me to how to force a widevine reinstall, I was thinking that maybe that was the issue, especially since I can authenticate to Amazon fine and load my playlist, but then it dies when I try to launch anything from the list.

Thanks!

#5

If you had it installed before the upgrade,I would try to uninstall the add-on and reinstall it.

If that doesn’t work i’d uninstall add-on, remove .kodi/cdm folder and ./kodi/addons/script.module.inputstreamhelper. Reinstall add-on and let it reinstall inputstreamhelper and libwidvine.

If that doesn’t work I’m out of ideas

#6

OK, I’ve uploaded logs here: https://paste.osmc.tv/emohusuzit

My steps since my last post have been as follows:

  • uninstalled Amazon VOD plugin (via gui)

  • via ssh:

    rm -rf ~/.kodi/cdm/
    rm -rf ~/.kodi/addons/script.module.inputstreamhelper/

  • reinstalled Amazon VOD and signed back in.

Was something supposed to happen on screen indicating that widevine reinstalled? I couldn’t see anything. In fact, I no longer have the folders I rm’ed above. Oops.

After all that, attempted to launch a video and still got errors. If anyone has further suggestions I’d be interested.

#7

I may have gotten somewhere actually on my own.

via ssh, I ran the following:

git clone https://github.com/emilsvennesson/script.module.inputstreamhelper.git

copied that folder to .kodi/addons/

uninstalled and reinstalled Amazon VOD

Next attempt to launch a video initiated the Widevine install process

It works!

#8

Nice, glad it works again.