An error occured while writing the image!

I don’t understand why I can’t install the image on my SD card

How are you trying to install it? The OSMC Installer? Which OS are you running on? Are you using Admin Rights?

Yes, I am using the OMSC Installer. I am on a Mac (Catalina) and I’m using the administrator privileges.

This is what I see at the end of the operation.

And this is the log file if it can help:

I also had tried to use a local build on my computer but seems like I have the same error.

Installer seems to currently not work on Catalina.
Use etcher to write the image

it gives me this mistake:

Try extracting the image first. It might be needed for Etcher.

I just use my friend PC (Window) and everything seems to work

Btw thanks a lot for the answers

Hello, another mac user here (macOS Big Sur 11.6, M1) and I was encountering the same error in the installer. My error also matched the error in the OP’s log (“Operation not permitted”).

Just wanted to offer another workaround:

  1. Look in the log for the line that says “pasting admin script to process do shell script” and copy the command script (it appears in quotes and looks like “dd if=/Users/edmond/OSMC_TGT_rbp2_20210808.img of=/dev/rdisk6 bs=1m conv=sync && sync”
  2. Open Terminal and run command with sudo: “sudo dd if=/Users/edmond/OSMC_TGT_rbp2_20210808.img of=/dev/rdisk6 bs=1m conv=sync && sync”

After that, I was able to place my SD in my pi and run the rest of the installation.