Android - Raspberry Pi | Yatse issue

I have got a problem with my Raspberry Pi. It is running OSMC. I have got an external hard disk attached to it, where i have got all my media and it is mounted in /mnt/usbhdd
I would like to take the audio output of a film from OSMC to Android, so i could have video output from my tv and audio output from my Android smartphone, with headphones.
I googled and found Yatse app, i bought the Premium version, but i couldn’t get to play locally or to download a film (error 401).
I tried to resolve this problem following this guide (that is exactly my problem):

I added a new source (via file manager) pointing /mnt/usbhdd/Film
But again the 401 error is showing up.
Someone could help me?

I tried to explain in the best way my situation, i hope you can aproximately understand.
I apologize in advance for any grammatical error, but i am italian.

I’m not all that technologically minded, but I don’t think what your trying to achieve will be easy to implement, let alone sync (more than happy to be corrected if I’m wrong). Perhaps consider some wireless headphones connected to the 3.5mm output from the pi?

Yatse is still an incredibly useful tool so don’t feel you have wasted your money, I have the premium version myself.

1 Like

OSMC’s experimental A2DP support can probably do this

1 Like

I think it is easy to implement because Yatse offer the possibility to play media locally on your smartphone, but i can’t get it work.
Yes, i considered the option to buy Wireless Headphone but i wanted to solve the problem in this way.
I know that i haven’t wasted my money, yatse is a great project and it is a simple contribution to developers to continue on this way.

This is definitely working between OSMC and Yatse, are you sure you have setup everything correctly including UPNP and Webserver (and correct username/password). How to configure Kodi for Remote Control access

1 Like

I don’t know what i did, but the problem is solved, it is working, thanks to all!

Hi, could you share your osmc system settings?

1 Like

Yes no problem, exist a method to simply share sysem settings? (OSMC could automatically create a .txt with all the system settings?)
I followed the guide that was posted by fzinken for the service settings.

Hi, I solved the issues:

  • Removed all the sources

  • Re-added manually inserting the complete path of the source


1 Like