App Store doesn't work


#1

Hi, I installed the latest version of osmc on my raspberry pi b+ using the osmc installer but when I click the app store button it doesn’t do anything


#2

Please provide respective debug enabled logs so that we can help.


#3

I saw the kodi.log and when I click on App Store, the log writes this:

WARNING: CPythonInvoker(6): Script invoked without an addon. Adding all addon modules installed to python path as fallback. This behaviour will be removed in future version.


#4

You need to provide us with the link to a full set of logs as the link provided above describes.


#5

sure, I’m sorry, this is the full set of logs: http://paste.osmc.io/isiwanuzoc.vhdl


#6

Can someone help me?


#7

You seem to have some network issues. Can you report what happens when you run
sudo apt-get update && sudo apt-get dist-upgrade?


#8

Hello,
I have the same issue. I just freshly installed osmc and added a few add-ons (some of them are unofficial). I’ve performed update&upgrade as mentioned above. The log is here: https://pastebin.com/0vJXLnpp
Could you advise where to look for a cause of that issue. I would like to install Transmission. Thank you in advance for taking a look on that.


#9

The Kodi log is not useful for this type of issue. We need to see the errors that return when you run the update and dist-upgrade commands.


#10

Sure, but there are no errors: https://pastebin.com/uEmzEFqe
Actually one clarification: when I click on “App store” it opens but kinda stucks while rendering the page - I can see the list of apps and first one seems to be highlighted. Unfortunately I cannot do anything there (it doesn’t react) except pressing “back” button.


#11

You are using Kodi Leia, check the Leia testing thread. The MyOSMC addon has a navigation issue. A workaround is explained in there.