Apple TV 1st generation - unable to install to local hard drive

Hey there,

First time posting. Got a pretty easy question, I am hoping.

I have two Apple TV 1st generation models (both with BC HD decoder cards installed). Recently, I decided to wipe my current hard drive install of OSMC and re-install with the latest image (May-2017). Both OSMC installs were installed to the local hard drives as I wanted to re-use the USB keys for other purposes and I have two other Apple TV 4s and so I really have no use for the 1st gen other than to use it for OSMC.

I have done OSMC installs before and never had any trouble but for some reason, I can no longer install OSMC to the local hard drive of my Apple TV.

I am using the OSMC installer on the latest version of Mac OS (10.12.6). I chose the hdd install image as I have done before and it eventually tells me that the USB key has been successfully created.

First time around, I used the latest image (as I noted above) and never did see a message asking me to remove the USB key. Once OSMC was loaded, I removed the key and the screen then became distored. I then tried to boot the Apple TV WITHOUT the key and I get the flashing question mark symbol atop the Apple TV icon. As soon as I insert the USB key, it boots into OSMC. I then tried the March-2017 image but the same thing happened.

I started reading through the WIKI but couldn’t really find anything useful that might solve the problem. So I decided to try and restore it back to factory, which worked as expected. As I wanted to try the OSMC install from a factory-restored (fully updated) image, I made sure the output was set to RGB high then re-did my USB key again using the OSMC installer and selecting the most current image version. Again, same issue where it installs itself to the USB key even though I selected the HDD install. If I remove the USB key and boot the Apple TV, it boots into the original operating system for the Apple TV. If I boot it with the key inserted, it boots into OSMC.

A bit perplexed as I have done this before. I have a great deal of experience with Linux and anything you ask me to provide I’ll be able to do. I’m wondering if it is the OSMC installer for OS X that is the culprit here?

One question I would like to ask is this: is there any difference between running OSMC from a good USB 3 (backwards compatible) drive versus running OSMC from the internal hard drive? If there’s no real benefit other than additional storage, I’ll probably just leave it run from the USB drive.

At one time, I was able to find a step-by-step install of OSMC for the Apple TV and I looked around in the WIKI but I’m having trouble locating it. Also, I saw a post by Sam that said there’s really no point of a walk-through as it’s as simple as creating the key, booting from it and waiting for the install to complete.

Thanks in advance folks.

This means you have selected the wrong image

Hey Sam,

I thought so too, so I checked on my hard drive for the image that was downloaded and the image file has the letters “hdd” in the file name. I deleted the image file and re-downloaded it using the installer, again making 100% sure I selected the correct image (image file name has -HDD in its title when selected from the installer). As I’ve built images before, I thought maybe the USB image was accidentally used and given the HDD name. This is when I decided to try the March HDD image and arrived at the same result.