AppleTV brick?

I had OSMC install on HDD but forgot to set the AV to “RGB High” so needed to put Apple TV OS back on.

Nothing seems to work with regard to putting ATVOS back on and now OSMC is also not responding.

I have build USB sticks for ATV OS 3.x from - Restore AppleTV OS after erasing disk (Offline Method) which says reboot and use Remote and + to force re-install (my Alu remote has no + but I am guessing its the Up button). But I never get any image to see if it is restoring.

I’ve build USB and HDD OSMC sticks but my ATV seems to do nothing with them.

I appreciate its old and largely junk hardware but I dont want to just throw functional kit out.

Try another USB stick.

Thanks Sam, tried a 4th stick this morning… still just stuck with blinking orange light and no display… after 30 mins or more of waiting

Is it possible I could solve by removing HDD and attaching to a Linux PC and using DD? I notice there are two partitions (one with Apple format) and one with a big Tar file for OSMC in installer. Ideally I’d be able to restore the ATV OS itself if someone has a backup somewhere, then fix that RGH High and then put OSMC back on.

Whatever RGB was set as in the original firmware doesn’t matter since it is (properly) overridden by the Nvidia driver when running Linux anyways.
In xorg.cong you can change
I don’t remember what the default setting is but I think it is RGB LOW. In all practicality that won’t matter since when the driver loads it will change metainfo in the HDMI stream and your TV will change accordingly.

The VBIOS is RO from Linux.

It is but it doesnt matter. Maybe you didn’t know, but it can be set inside xorg.conf.

To be clear: Let’s say you have pink screen at startup, and you think you need to restore to atv os to change the hdmi output setting: well you don’t, it can be set inside xorg.xonf. You still get a few moments of pink screen at boot but once inside Kodi, it will be fine.

(The reason for the pink screen is that sometime when atv outputs YCC the TV somehow thinks it’s receiving RGB, and also sometimes it resets to this by itself even though you have chosen hdmi low or hdmi high in atv os settings. It seems the hdmi infoframes which tell the tv what colorspace the atv outputs, have some compatibility issues, at least with some tvs, until the driver is loaded)

It will still cause problems on the frame buffer.

Newer NVIDIA drivers don’t parse this anymore, but I haven’t looked at the Apple TV in a long time. It’s no longer supported by OSMC.

If you plug the aTV in to any Philips TV from 2009-2011, you’re definitely going to have a problem.

I havent noticed any problems whatsoever.

Not sure if I understand you right… dunno about newer nvidia drivers in general (although I kinda refuse to believe you cant change the colorspace and range for the typical nvidia gpu in Linux), but this was just about the Apple TV and only that, including the latest 304.137 driver.

Maybe older philips tvs have problems at boot, but once inside Kodi even they will work fine, at least if you have defined the colorspace/colorrange inside xorg.conf.