AppleTV Install can't select Install location

I’m trying to install osmc on my AppleTV
I go through the installer, but when it gets to the section on “where would you like to install OSMC” I cannot install to a USB stick, in fact all options are greyed out and it is locked on “on an SD card”


Just select the USB image and it will install to a USB stick just fine. This has been covered before.

Sorry, I had tried that but the USB didn’t show up in list of devices… I forgot to make sure it was formatted properly. My bad. Thanks for your timely response!

How did you format it? I cannot get the ‘on a USB stick’ to light up when trying to install the HDD image. Do I need to be hardwired to internet to install the remaining files?

It’s meant to be greyed out, just click continue in the installer.

Nothing is showing up in the device selection part. Maybe its my cheap USB stick. Ill try a different one.

Worked with different USB drive.

I progressed past and as it was trying to install to my thumbdrive it bricked it :confused: Couldn’t even re-erase the volume in diskutility.