AppleTV1 is laggy and reboots constantly since update

Mine crashes, when I try to stream videos:
Feb 10 20:59:00 osmc kernel: VideoPlayer[2303]: segfault at 0 ip 0873547b sp 9fbfec60 error 4 in kodi.bin[8048000+24df000]
_ Feb 10 20:59:01 osmc mediacenter[1360]: xinit: connection to X server lost_
_ Feb 10 20:59:01 osmc mediacenter[1360]: waiting for X server to shut down (EE) Server terminated successfully (0). Closing log file._
_ Feb 10 20:59:02 osmc sudo[1725]: pam_unix(sudo:session): session closed for user osmc_
_ Feb 10 20:59:02 osmc mediacenter[1360]: Kodi exited with return code 0 after 0 hours, 19 minutes and 36 seconds_

We need full, not partial logs, with debugging enabled.

Fox example crashes at 21:21:08 and 21:22:40


Guys, do you have any updates about ATV crashing, when I try to run video stream?

I did a clean install by first reverting to ATV software, updating, and modifying the settings as I was instructed to elsewhere, and then used the OSMC installer patchstick thing and everything was working well. Updated to most current again and this time I didn’t add my media to my “library” so I avoided downloading all of the fan art and thumbnails, etc.

The only problem I can’t seem to correct is some videos are really laggy. I think it might have to do with file size… but I can’t quite figure it out… Definitely an issue I’m having on videos I never had a problem with before.

I have not had any problems streaming but i only use 1 add on for streaming.

Which addon would that be?

It seems that most of the “laggy” videos are mkvs but not every mkv file plays laggy… not really sure why some are OK and some aren’t and it doesn’t seem to have to do with file size…

could it be possible that my Broadcom HD graphics card or whatever it is called is failing? Any way to be sure?

Krypton version has a bug with the CrystalHD card being detected but not being used for video playback.
Sam is looking into it.
There’s a thread about it, here in the Apple TV section.

Thank you! I will check it out. Seems like sometimes the problem goes away after a reboot and then usually reappears after it goes to sleep for a bit.

The ATV has so little RAM and the processor is old so it’s easy to overload it, and have it slow down.
Normally, the CHD card is there to take some of the load off the CPU, but without the CrystalHD card working, due to the bug, it’s just can’t handle HD videos.
I’m guessing that it works for a while when you reboot, because that cleans out ram.

Due to the increased demands that Krypton v17 Final puts on the ATV, it’s probably going to be a bit slower than Jarvis anyhow. Though I can’t say for sure since I don’t really use my ATV anymore, and it’s especially hard to tell until the CHD bug is squashed.

Seems the issue may be directly related to handling the icons size? Common ya make the operating system for ATV1 fully knowing its RAM memory limitations. So maybe we need to go down that path so that ATV1 is useful again. Thanks I hope ya figure out soon.

Could make sense. While navigating I was monitoring the system load using “top” and noticed the swapd being the top process when the UI started freezing up and sometimes crash right there after.

Same problem to me.
Atv froze and reboot when i scroll into the add-on(s) internal list.
It happens with every add-on

It’s a shame, because kodi 17 seems to be more smooth and fast then 16.

I’ve tried with my three Atv:
One with chd and usb installation
Two without chd and HD installation

This is my log from usb and chd

Thank you Sam for your good work,
and I hope you will think again to leave the Atv1 without osmc upgrade from next year :pensive:

It seems to happen when kodi try to load the image of the film (poster, fanart…)
I think, 'cause i’m noob
(Sorry for my poor english :relaxed:)

I’m new to the OSMC on ATV setup as I’m trying to find a replacement to the native OS since Apple has crippled its access to the iTunes store, which renders it useless. This happened once 3 years ago but they fixed it but it has happened yet again. (Stroll over to the Apple forums for details).

I am having a similar issue with mine with the performance. I noticed while updating my library (approx. ~750 movies over an NFS share) that it ran out of swap (only 128MB provided out of the box) and the OOM killer whacked the main kodi process:

[40474.728997] Out of memory: Kill process 3419 (kodi.bin) score 614 or sacrifice child
[40474.729004] Killed process 3419 (kodi.bin) total-vm:661316kB, anon-rss:124152kB, file-rss:17016kB

I was able to keep it from crashing by adding a 1GB swap file, but now the thing pages out for stretches at a time with IO/WAIT at 90%+.

Unfortunately the 1st Generation AppleTV has a very limited amount of memory; so if you are using large libraries, you will need a better device.

I would recommend not using library mode on the Apple TV.

Sam - thanks for the input. I wound up going a different route in my research/testing with the OS/kodi version on the ATV and found a version that is working great - memory usage stays consistently around 50%.

Great – glad to hear things are working well for you now.