April update breaks RPi 3

After installing the April update on my RPi 3, OSMC reboots in 640x480 resolution, and is unable to connect to my network server for media. The connections are still there, but any attempt to use them produces an unable to connect error. OSMC does have a network connection, and can see my network, it just can’t connect to anything.

I have downloaded the 2018-12 image to restore the unit, and that worked fine… until it downloaded and installed the April update and then the same result… 640x480 resolution and unable to access network links.

I’m re-imaging again with the 2018-12 image and will have to disable updates until we can figure out what is going wrong.

Let me know what information or logs you might require to help debug / diagnose this.


Well I doubt that we can figure out whats wrong if you don’t upgrade.

  1. For resolution you would once need to set the resolution to what you prefer e.g. 1080p than it should work. If that is that working than we need to check your disp_cap, a full log (e.g. via grab-logs -A will tell us. It might make sense to upload a grab-logs -A from your December install and after the upgrade.

  2. For Network issue you need to first tell more:

  • Which Protocol you use?
  • Kodi access or fstab?
    We only can trouble shoot that with this information and after you upgrade.

I can change the resolution without issue, it’s odd that it reset it to 640x480 though, I haven’t seen that happen with any other updates.

The logs on the device after rebooting with the 2018-12 image and setting up my server for videos has been created as https://paste.osmc.tv/avufawitin
After grabbing the logs, I ran “sudo apt-get update ; sudo apt-get dist-upgrade”, and then rebooted. Just prior to rebooting it did ask about replacing the ssh_config. After rebooting I once again saw the 640x480 screen resolution. The logs after that are https://paste.osmc.tv/mejaqivusi

The media server is a synology NAS and I am using upnp to connect them. With the 2018-12 image I can mount them via SMB as well (although I didn’t as the logs show).

I did notice that when attempting to add files, that upnp was not in the list of options after updating. Zeroconf was, and it could see the server, but only as SMB (and could not connect).

Networking is functioning though, I ran the grab-logs -A command from an ssh login, and can ping the meida server just fine.

When I diff’d the two sets of logs the 2018-12 log contains the following two lines shortly after “Running the application…”:
NOTICE: starting upnp client
NOTICE: starting upnp renderer

These are both absent in the log after updating.

Hopefully the logs give you more clues


Well upnp is really not a suggested solution for the client server configuration for Kodi.
Anyhow based on this thread upnp seems to be disabled by default on Kodi Leia, so you may just need to enable it in settings.

That is not surprising, but can you confirm that once you change it after the upgrade it sticks?

Yes it is working after making that change. Thank you.

The RPi is connected to a TV via HDMI, it has always properly detected the available resolutions in the past, it does seem odd that this release gets it wrong. The resolutions do show up in the menus for changing it, so this really seems like perhaps trying to retrieve the EDID information before the hardware has had a chance to read if back via HDMI.

As for the UPnP/DLNA it seems an odd choice in this release to disable it, especially during an upgrade when the config actually shows it being used. I know UPnP is old, but DLNA is the newer/better replacement, so I’d like to understand why using this for connections “isn’t recommended”. Is there something inherently wrong with DLNA that causes issues?


Well as I read in that thread upnp doesn’t support the Kodi Library function. This would be a main concern.
Also in general dlna/upnp is more for dynamic/adhoc connections and not permanent client/server connection that Kodi is designed around

Huh? What? Using Kodi Jarvis on my WIn7 machine - it’s libraries catalog my video files. The ~only choice~ Kodi gives me in sharing it’s library is UPnP, which work(ed) great with OSMC as a video source.

NOW, with April Update - UPnP was set to disabled - an ungainly practice and an ugly surprise.
Found and fixed.
EXCEPT: now when a video runs to completion and stops (from my Pi3), it crashes my Kodi on my Win7 machine.
So ~something~ has changed - which needs to be addressed.

UPDATE: I thought the crash was related to the video running to length and terminating.
Not always so. Just now stopped a 42 min vid at the 41 min mark and it still crashed my Kodi instance on the WIn 7 machine.
So after ~a length of time~ something gets sent that makes the server unhappy.

ALSO: I know I’m new here to this forum format - What is this ~highly distracting~ FLASHING CHECKMARK?
How do I get rid of it? Make it stop. Please.

No idea, never seen that here, provide a screenshot maybe?

Centered below the reply box.
Seems related to typing - only shows up occasionally.
Bright flashy circle deteriorating into an attention demanding checkmark.

In advance: thanks!

It’s saving the progress of you writing your post.

Oh, well. It’s simply awful. Notifying me of something I don’t need to know and can do without.

I suppose I’ll find a filter. Thanks for honoring my question.

Update from above:
Noticed the crash to the server, more than upon video end, comes after a length of time.
Stopped a 42 min vid at the 41 min mark manually. Still crashed my Kodi instance on the Win 7 machine.
So there we are.
Looking forward to a fix, un-relish the idea of re-imaging for a rollback.

With a sane choice of terminal colors, I can say that it’s never really been a distraction. Additionally, no one else has ever complained about it on this forum :wink:


You helped me understand the nature of the beast and how I can slay it.
People everywhere tolerate amazing levels of inhumane things and call them normal.
I’m here to call them out for what they are on a human level.
Meanwhile - OSMC works really well and I appreciate your all’s hard work.
I hope to contribute even from my low-contrast world.
What? You’ve never experienced the simplistic joy of working at a green-on-black text-only terminal?
Y’all are missing out.

While we are all entitled to our own opinions, we each must also live with the consequences if our choices. Enjoy your day and your OSMC!