April Update broke


I have had a Vero 4K for a while now without any major issues. After this update however it behaves very odd. It takes a very long while to start any movie, it’s just showing the buffer circle. If I jump to far in the movie the Vero crashes and restarts. If I come back the next day and turn on the TV, the Vero only shows a gray screen that can only be solved by pulling the power and restarting the nasty way. I can’t hear and interface sound if I use the remote when this occurs either. Is anyone else having these problems or is there any other thread? I can’t use the Vero at all in this state… The movie are all 4K 10-bit from a NAS if that matters for the first problem.

The following log-file is from after reboot and crash when jumping to far in a movie. Will upload another logfile when the grayscreen happens.

Update: The gray screen happens when I turn off and on the reciever its plugged in to.

Movie crash log - https://paste.osmc.tv/ivaxoqegem
Gray screen log - https://paste.osmc.tv/qipikolopo

Update 2: I have a friend with the exact same problem.

Nearly the same for me. Which protocol are you using to connect to the NAS? SMB/CIFS, NFS? Is it mounted via kodi or via fstab?

Connected via SMB, no idea what fstab is so Kodi I guess

I haven’t been using my vero too much recently but I did noticed I had a few crashes and restarts when skipping ahead in a few 4k movies after I updated.

I haven’t had the time probably test it yet.

We STRONGLY recommend you set the resolution of the GUI to 1080p. There is no benefit to setting it to 4k and you should always get a picture at that whichever order you turn on your devices.

The crashes will take a bit longer to analyse.

Edit: I can’t reproduce the crashes with your settings, but please try a 1080p GUI resolution and setting Player-Adjust display refresh rate to ‘On Start/Stop’. That way your 4k24Hz videos will play at 4k24Hz.

I have now changed your recommended settings. Will report back if it solved the gray screen.
The crashed however still occour. The only way I can force the crash is to watch a 4K HDR movie and jump about an hour in. Small jumps are ok, but when skipping too far it will crash.

I also have another problem, unrelated to this, i think. It has been with me longer than this April Update.
Sometimes, very randomly (About every 30th time) I stop a movie and return to the homescreen, it will do this: https://i.imgur.com/6CVY9z9.jpg
This also requires a restart to fix. It still says the resolution is 1080p in the settings though.

Any updates on this issue?
I still can’t fast forward in 4K HDR movies. A friend that has a few of these has the same issue.
@grahamh @sam_nazarko

Sorry, I don’t have any 4k HDR movies to test.