April update causes System freezes

Well so far for me it hasn’t froze once. Have been going through the gui fast, skipping forward and back while playing. Cant seem to get it to happen. :grin:

Can you be clear about what you testing? Is this a clean March install, or did you update to Sam’s new piX-mediacentre.deb file?

Sorry, I have updated to the version Sam linked 16.1.0-7

FWIW, I backrevved to 2016.02-3 and restored settings. Will see how it goes. Most of the issues with the new version has been when fast-forwarding a recording from TvHeadend. (F-key). This has often rendered the unit unresponsive for a long time.

Apart from the new playback freeze, the thumbnail freeze still can be ‘fixed’ by uninstalling smb service.
I wonder what is the connection there… did anyone look into that?

I’m not sure why this would be.

Can you clarify what you mean by SMB service? Do you mean Samba Service from OSMC App Store? Because of the way dependencies work, uninstalling from the App Store won’t actually remove the Samba server. This will be remedied in the future.

Sam

Yes the samba server* from the App Store, as described in this post April update causes System freezes

Okay

But as explained – uninstalling Samba Server from the App Store will not remove the smb.service in its entirety. I’d be interested in knowing if a fresh install without Samba Server experiences any problems

Sam

What does uninstalling the server from the “app store” actually change then?
BTW there is at least one who has the ‘freezes’ without samba server April update causes System freezes

Gonna do a fresh install then…

Honestly – not much. It will still leave a Samba server running.

@popcornmix @sam_nazarko OK, been using a Krypton build for the last 4 days and have had no recurrence of these issues.

dpkg -l | grep mediacenter-osmc | awk ‘{ print $3 }’
16.8-083

It is running on one of the problem Pi B+ using the new ‘standard skin’ it has all of our normal addons mythtv etc.

It has been stable since upgrading from the 079 build.

Cheers
Spart

But there must be something with that impact…

Flashed OSMC_TGT_rbp1_20160502, setup movie database, and can browse it without freezing.
When its done scanning the TV shows too i will give the samba server a go…

PS: installed samba from store, rebooted: freeze browsing library. @sam_nazarko @popcornmix

Great! I’ll try to disable SMB and try it too

It froze in the gui again last night and no errors in the logs :-1:t3:

then this is a little weird, isn’t?

Definitely! For me it didn’t really fix the issue but let it occur less often.

this is my logs:

20:41:18 2715.285156 T:1956647856   DEBUG: Activating window ID: 12005
20:41:18 2715.287109 T:1956647856   DEBUG: ------ Window Deinit (MyVideoNav.xml) ------
20:41:18 2715.291260 T:1285673968   DEBUG: CDVDPlayer::OMXDoProcessing Resume 0.21,0.20 (A:01 V:01) EOF:0 FULL:0 T:0.20
20:41:18 2715.291504 T:1285673968   DEBUG: OMXClock::OMXSetSpeed(1.000) pause_resume:1
20:41:18 2715.291748 T:1285673968   DEBUG: CDVDPlayer::HandleMessages - player started 1
20:41:18 2715.291992 T:1285673968   DEBUG: CDVDPlayer::HandleMessages player started RESET
20:41:18 2715.291992 T:1956647856   DEBUG: ------ Window Init (VideoFullScreen.xml) ------
20:41:18 2715.292236 T:1285673968   DEBUG: CDVDPlayer::HandleMessages player started 1 (s:1000 a:1 v:1)
20:41:18 2715.303711 T:1515189232 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
20:41:18 2715.305420 T:1956647856   DEBUG: OMXPlayerVideo::SetVideoRect 0,0,1280,720 -> 0,0,1920,1080 (0,0,0,0,mono)
20:41:32 2729.445801 T:1495266288   DEBUG: Thread JobWorker 1495266288 terminating (autodelete)
20:41:32 2729.446289 T:1670525936   DEBUG: Thread JobWorker 1670525936 terminating (autodelete)
20:41:32 2729.446533 T:1486877680   DEBUG: Thread JobWorker 1486877680 terminating (autodelete)
20:41:37 2734.172363 T:1459614704   DEBUG: Thread JobWorker 1459614704 terminating (autodelete)

UPDATE:
about the freezing, yesterday everytime i play a video kodi froze. so i tried the second kodi that accessed vidoes in hdd via nfs, it also froze, so power off kodi1 and same videos played again ok. also in kodi2 via nfs
so maybe something related to mouting the HDD
never had that issue before. haven’t changed anything related to mounting

Yes – it’s odd.

What happens if you install OSMC and don’t install SMB Server from the App Store? Do you still get the freezes?

This thread has become quite disjointed and confusing now that we are long past the April update. The dog piling +1’s and me too’s is difficult to navigate to useful info. Now that the issue is outside the scope of the OP, the thread will be closed. Users with an issue that persist should create a new and appropriately titled thread for continued support.

Thanks.