April update causes System freezes

Since osmc on my raspi b+ Has updated a few days ago it Has started freezing and loosing movie and TV Show images, Banners and so on.
If it sits idle for some hours, it seems to loose all the images, except the ones, that were visible when last used.
If i try Playback then, it freezes, only showing the loading animation. I have to unplug and Reboot to get it working again.
files are Provided via nfs, and we live on a shared mysql library, all of that works fine for all my other kodi Devices (Linux and android Powered devices on a wide range of hardware)
sadly im not ner the raspi right now, but i’ll be able to provide demanded logs later this evening.

1 Like

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

Just Enabled debugging, but as it is a Problem that requires Several hours of idle time, it will take some time.

Hey I have also had some intermittent freezing on my Raspberry Pi after applying the April update. Its hard to nail down but so far the most predictable way to cause it to happen is to use Music > Party Mode to queue up some tracks, then one or two tracks into the playlist when moving to the next track it freezes with the screen saver up. At that point I can use the Kore remote to exit the screen saver at which point it switches to fully frozen.

I managed to replicate that with the debug display up and while the screen saver was up and moving to the next track was frozen the debug output on screen was active, once I used back via Kore the debug output froze as well. I didn’t manage to grab the log for this however but am trying to replicate it again and will send a copy of the debug log through when I do.

Other than the freezing between music tracks video playback seems fine and I haven’t had any freezing so far.

When Kodi crashed and restarted the old log will be stored in kodi.old.log so you can upload any time.

Oh good tip I didn’t know that was kept around. I have copied the log file contents here - http://paste.osmc.io/kogilipepu.coffee.

Exact same problem for me! Sometimes it happens after several minutes, other times after several hours.

I’m in work now, but I will try to get a log for Sam & co. later.

Does the issue only affect Pi1, or also Pi2/3?
Can you find a simple repeatable way of provoking the issue?
e.g. if you take an mp3 and add to playlist, set the playlist to repeat and the leave it playing does it hang?
If so, can you find a very short mp3 (where the start/stops occur more often) which may fail more quickly.

Do any settings stop the issue? e.g. disabling visualisation or screensaver?

I’m experiencing this problem as well. But in my case Kodi frezzes whenever I open my video library and the covers are rendered. Some covers are shown, others are not but I’m actually able to select different movies. When I try to play a movie, only the loading animation is shown. The same applies for my music library.
I’m using a Pi1, the Confluence theme and the Thumbnail view mode in my libraries.
Interestingly I’m able to log in to my Pi via ssh.

I’ve had a quite similar problem some time last year. Unfortunately I don’t remember which update fixed the problem for me.

Than provide logs with grab-logs -A

Here are my log files: http://paste.osmc.io/vobobuzuca

The GPU doesn’t respond to a jpg decode.
Hard to say why - insufficient power supply could be one reason.
Possibly there is a malformed jpg causing an issue.

That may be in the thumbnail cache.
You could try moving ~/.kodi/userdata/Thumbnails and ~/.kodi/userdata/Database/Textures13.db in case something there is corrupted. It should regenerate the cached images.

http://paste.osmc.io/woqetexara
More recently, it’s currently trying to Start Playback (for Several Minutes now) http://paste.osmc.io/usolivovoy

I’m home now and reproduced the problem. The logfile was too big for paste.osmc.io (I tried grab-logs -a but it failed) so I’ve had to upload it to TinyUpload here (15 MB).

I rebooted OSMC this morning at around 11.00. It was still running fine when I came back from work. I listened to party music mode for a while and no problem. I then watched a video and nothing crashed. After, I initiated party music mode again and put it in full screen. It was fine for about 25 minutes. It froze at around 22.00.

The system (RP2) isn’t completely frozen. I can still SSH in and access files via samba. They keyboard isn’t responsive though and all I see on the screen is current track of the playlist. The time is at 00:00:00 and nothing progresses nor do I hear anything. The debug text on the top left of the screen is frozen too, it’s not being updated…

Happens to me also on RPI1. If i let the system idle for some time I cannot play anything. It just locks on trying to start the video.

I just Removed Textures and thumbnails, ill report if it works

Are all these reports a new issue in the April update?
Does reverting to March version avoid the issue?

The problem just happened again. This time my log file is smaller so I could upload it to paste.osmc.io: http://paste.osmc.io/sobunuhobo

Again, it happened just as a new track was starting in party mode at 21:56

I never tried the March version of OSMC so I can’t say, but perhaps somebody else can weigh in on that.

Clearing thumbnails and textures didn’t help.
Once it has played something and then sat idle for a while it freezes when I try another playback and doesn’t show images anymore that were out of view when the idle time began

System froze again twice this evening.

The first time was in the same way as the previous times (party mode full screen) http://paste.osmc.io/jujavawole

The second time was in a different way. I had three albums queued. Kodi was in the home screen (Confluence). The track just stopped playing about 10 seconds before finishing. The track was just suspended without making progress or sound. Log file: http://paste.osmc.io/qiqirocuve

1 Like