April update has broken argus pvr

Hi there, newbie here. Running OSMC on RPi3 using the ArgusTV PVR addon - been working for some time on kodi 17. Today, I applied the April update and now kodi crashes on startup with a sad face. The RPi itself does not crash, just kodi. Deleting the Addons27.db allows kodi to start. Adding the ArgusTV PVR addon immediately makes it crash again.

I have uploaded the logs here: https://paste.osmc.tv/ibipetumaf

The error appears to be due to the wrong version of the ArgusTV addon:

May 03 20:59:49 osmc mediacenter[3181]: /usr/lib/kodi/kodi.bin: symbol lookup error: /usr/lib/kodi/addons/pvr.argustv/pvr.argustv.so.2.5.4: undefined symbol: _ZN4Json5ValueixEi

I thought that the krypton build of the addon should be 2.5.5 rather than 2.5.4 but I might be wrong.

In my ignorance, I’m not sure whether this is an OSMC issue or something wrong in the relevant kodi release?

I’m hoping that I don’t have to re-install an older version of OSMC from scratch but I don’t know of any way of downgrading to the version before the update.

Thanks for any help!

Exactly the same problem for me.


I just installed krypton onto an Ubuntu 16.04 VM and then installed kodi-pvr-argustv. I got this:

Setting up kodi-pvr-argustv (2.5.4-3~xenial) ...

The kodi log shows:

NOTICE: Starting Kodi (17.1 Git:20170320-nogitfound). Platform: Linux x86 64-bit

So it looks like krypton is still supplying 2.5.4 for Kodi 17.1

As to the actual error, they can be very difficult to debug. The undefined symbol _ZN4Json5ValueixEi can be found in the library as undefined, meaning that it tries to find it in another library at run time. Where it should be and why it’s not finding it are the key questions.

Thanks, a dog called Dill. If the standard kodi install is using 2.5.4 then I think I need to go ask on the kodi forums and see if anyone has any ideas there. It has to be the latest update that has broken things so in the meantime I’ll re-install a slightly older version just to get kodi working otherwise I’ll be under pressure to go back to Mediaportal on a PC which would be admitting defeat!

Definitely worth asking on the Kodi forums but the add-on is developed independently from the core Kodi system, so you might get a better response from the Argus forum ARGUS TV - Index page .


Does anyone have an update on this? I experienced the same problem and ended up restoring a backup after reading this thread. I’ve been holding off on updating to kodi 17.


Have you tried with 17.2 (2017.04-2)?

Hi Sam

Yes. I just got around to upgrading to 17.2 last night. The ArgusTv client is disabled by default so Kodi came up without issue. As soon as I enabled the add-on, Kodi entered an infinite crash loop.

Do you have any suggestions that I should try before applying my backup again?

Wait for 17.3 which is imminent.

Thanks. I look forward to it.

@sam_nazarko, I installed v17.3 this afternoon. Same issue. Kodi is still crashing.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

The only error I have in kodi.log is this:

18:14:00.750 T:1958842368   ERROR: DBus: Error org.freedesktop.DBus.Error.ServiceUnknown - The name org.freedesktop.UPower was not provided by any .service files

I do have a warning about the Argus TV client:

18:15:37.380 T:1937765360 WARNING: GetAddonProperties - Addon ARGUS TV (McMillen-PC):http://McMillen-PC:49943/ does not support timer types. It will work, but not benefit from the timer features introduced with PVR Addon API 2.0.0

I can attach the full log if needed.

Also, I ran systemctl status mediacenter and got this:

Jun 07 18:13:25 osmc sudo[9990]: pam_unix(sudo:session): session closed for user root
Jun 07 18:13:25 osmc sudo[9993]: osmc : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/bin/cp /usr/share/zoneinfo/America/Chicago /etc/localtime.dpkg-new
Jun 07 18:13:25 osmc sudo[9993]: pam_unix(sudo:session): session opened for user root by (uid=0)
Jun 07 18:13:25 osmc sudo[9993]: pam_unix(sudo:session): session closed for user root
Jun 07 18:13:25 osmc sudo[9996]: osmc : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/bin/mv /etc/localtime.dpkg-new /etc/localtime
Jun 07 18:13:25 osmc sudo[9996]: pam_unix(sudo:session): session opened for user root by (uid=0)
Jun 07 18:13:25 osmc sudo[9996]: pam_unix(sudo:session): session closed for user root
Jun 07 18:13:30 osmc mediacenter[9783]: /usr/lib/kodi/kodi.bin: symbol lookup error: /usr/lib/kodi/addons/pvr.argustv/pvr.argustv.so.2.5.6: undefined symbol: _ZN4Json5ValueixEi
Jun 07 18:13:30 osmc sudo[9981]: pam_unix(sudo:session): session closed for user osmc
Jun 07 18:13:30 osmc mediacenter[9783]: Kodi exited with return code 127 after 0 hours, 0 minutes and 6 seconds

Does this help?

I’d guess from this error that your add-on needs to be built for the new kernel. You probably should contact the develop for help with this.

It’s exactly the same error as from the first post, back on 3 May, which was on Kodi 17.1 (and 4.4 kernel).

As I advised back in post #5, the best chance of a resolution is to contact the developers.

I have experienced the same problems.

Just for info, a Win7 install of Kodi (stable release), which has been updated with each Kodi update as they became available (currently 17.3), plays nicely with Argus.

Do you know what version of Argus TV you’re running?

I thought I’d give an update on where I am with this problem. I’ve applied the 17.3 update and ArgusTV addon is still broken. BTW my version of ArgusTV is 2.3, running on a Win7 machine,

Looking at the source code for the addon in github (GitHub - kodi-pvr/pvr.argustv: Kodi's ARGUS TV client addon) suggests that there have been no breaking changes, just a few minor bits and pieces.

Given the mention of json in the error message, I’ve checked that the libjsoncpp-dev library is installed and it is but maybe there is a version problem with this? I’ve even tried building the ArgusTV addon but hit too many issues with the cmake files and gave up.

It seems to me that if the ArgusTV addon is working in 17.3 on Windows (as reported above) and it also worked fine in 17.1 prior to the April update, then there must be a mismatched library somewhere on the rpi introduced by the update. I don’t have the skills to take this any further, unfortunately, so I’ve restored the older osmc image and will stick with that for the time being. Sorry i can’t be of more help.


I’m using 2.3 on a Win7 machine as the backend.


I have Kodi running on the same Win7 machine, with the Argus PVR plugin enabled. This Kodi install is the one that is regularly updated and works fine.

I have two OSMC installs on RasPi3s: one held on the 17.1 update (which still works with Argus); and one which I update when available, where Argus is broken.

I’m away from home for a few days, if you need more, just let me know.


I’m just wondering if anyone has gotten anywhere with this.