April Update made CEC worse, not better

Hello alltogether,

before the April Update, CEC worked allright: The remote of my Samsung TV worked reliably (after I updated the Samsung’s firmware). Now and then, the TV was switched on during the night by itself. I hoped that the latter would improve after the update.

Unfortunately, after the update the TV still switches on itself but the remote controll doesn’t work reliably any more. Many times, I had to let the TV search for CEC devices to reactivate the RC. I don’t think it’s the TV’s fault, as it worked like a charm after its firmware upgrade and before Aprils update.

How can I help to improve this?


Sorry to hear you are having issues. Debugging logs showing the issue, would be useful in helping diagnose the issue; details for which can be found here.

Component specific logging, for libcec will probably be quite helpful too. You find this is logging section on osmc aswell.

Thanks Tom.

Can you confirm that your TV isn’t connected to the Internet?

We had some Samsung ‘Smart TVs’ do some sneaky things with firmware updates and this sent us on a wild goose chase before, finding an issue that was actually caused by the TV vendor.

There were some changes to CEC in this update, but they were mainly to mitigate some problems with TVs powering up randomly.

This is indeed the thing we were trying to resolve. It has been acknowledged as solved by other users.

Some debug logs as @Tom_Doyle suggests will help



thanks for your help :slight_smile:
I can confirm that my TV has no internet connection. I deeply mistrust Samsung in all things of privacy, so the TV only went online once for the Firmware update. But just to be sure, I double checked it.

I’ll activate debugging. But given that the error only appears sporadically, I think that the logs can grow quite large, can’t they?

Yes – but they shouldn’t be so large that you can’t upload them. The maximum upload size is 10M


I’m still trying to get a log. Unfortunately, whenever I activate logging, no error happens. Heisenbug…

The good news is that there are improvements coming in the (slightly late) May update for CEC. I’d be interested to know how things go after this.


Sorry, no success. After the update, the TV woke up tonight and right now the remote control didn’t work…
I’ll keep trying to get a logfile.

Oh, and by the way: I have the same problems with my raspberry now as well: the TV turns on during the night and the remote controll doesn’t work :frowning:

CEC needs fixing upstream. We’ve tried to improve things but there seem to be too many devices out there currently. What fixes things for some users breaks things for others.

As soon as we have further developments we will make them available in OSMC.