April update xboxdrv not working

When you reinstall the previous kernel, it should just update that package. Other packages should still be current (i.e. Kodi 16.1). So its not a fresh start. Hopefully apt-get would warn you if there were any dependency problems (i.e. if something required the latest kernel). Xboxdrv worked for me once I rolled back, so hopefully it doesn’t cause any new problems.

Thanks for the tip! Is there a list somewhere with the releases? A quick google didn’t do the trick.
Looking for the version before september, somewhere around that time they introduced the random freezing bug and for some reason the old image I installed auto updated to a newer version now I just replug the pi when it crashes. If I could downgrade like this, that would have saved me alot of time.

woops downgrade found symbolic links
booted into a black screen. damn.

Here is one way to get a list of the available rpi kernels in the repo

apt-cache search . |grep image

Here are the current ones

rbp1-image-4.4.6-3-osmc - Linux kernel binary image for version 4.4.6-3-osmc
rbp2-image-4.4.3-3-osmc - Linux kernel binary image for version 4.4.3-3-osmc
rbp2-image-4.4.6-3-osmc - Linux kernel binary image for version 4.4.6-3-osmc

Doesn’t seem like there is an older 4.4.3-3 for rpi1, so I’m not sure how you’d roll back on that hardware.

Linux version 4.1.5-1-osmc (root@rpi2) (gcc version 4.9.2 (Raspbian 4.9.2-10) ) #1 PREEMPT Wed Aug 19 22:08:45 UTC 2015

installed august image this is the cat /proc/version output

@mrcake
Edit: or @jayOnJava

sudo apt-get install rbp2-image-4.1.5-1-osmc --reinstall

Will this get me back to august?

I wouldn’t try it on rpi1 if you like your configuration :smiley:

Pi2 is what I’m working with. I am pretty sure it will work but just wanted to ask.
Edit: didn’t work

Hi

Can you tell me:

  • The earliest kernel version that worked with xboxdrv. An image like 2016.02-4 would also be good.
  • journalctl of an OSMC where it works
  • journalctl of an OSMC where it doesn’t work

I have an Xbox 360 controller that is wired. Will I be able to use this with XBOXDRV to test? If so, can someone give me a quick rundown of how I can get it running.

Thanks

Sam

These are 2 places that got me started.

I never had any problems with Octobers update last year.

I could give you a journalctl of it not working but it will be a while as I am pull 12 hour shifts this week. Maybe someone else can help? Thanks for looking into it. I opened the issue.

Don’t post logs in threads, use paste.osmc.io, paste-log or grab-logs tools.

Please edit your post

I have no idea if aforementioned log is before, or after it worked. Either way, I need both.

It is from xboxdrv not working, as I mentioned in the previous post. My apologies. Anyways I tried. I cannot get both journals for maybe two weeks. I’ll edit my post. Didn’t know about paste.osmc.io sorry. Cheers.
Edit for grammar

Hi,

I used this guide [How-to] Xbox 360 Controller OSMC to install my wired controller.
It still works after the April update but the lights on my controller keeps blinking which is a little bit annoying when using it in my bedroom.

Floris

Is xboxdrv still working on latest kernel?

Getting errors

osmc@osmc:~$ sudo xboxdrv
xboxdrv 0.8.5 - http://pingus.seul.org/~grumbel/xboxdrv/
Copyright © 2008-2011 Ingo Ruhnke grumbel@gmx.de
Licensed under GNU GPL version 3 or later http://gnu.org/licenses/gpl.html
This program comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it under certain conditions; see the file COPYING for details.

Controller: Microsoft Xbox 360 Wireless Controller
Vendor/Product: 045e:0291
USB Path: 001:004
Wireless Port: 0
Controller Type: Xbox360 (wireless)

– [ ERROR ] ------------------------------------------------------
Error couldn’t claim the USB interface: LIBUSB_ERROR_BUSY
Try to run ‘rmmod xpad’ and then xboxdrv again or start xboxdrv with the option --detach-kernel-driver.

xboxdrv has told you the error. You need to blacklist the xpad module. Search if you are unsure how to do this.

Hi sam

I have blacklisted xpad which still gives same error as above. When i try the --detach-kernel-driver option its gives LIBUSB_ERROR_NOT_FOUND.

I posted on retrosmc forum see if anyone has any advice.

Type ‘LIBUSB_ERROR_NOT_FOUND’ in the search bar and check the results

I know this thread is old, but if anyone still has the LIBUSB_TRANSFER_ERROR on newer kernels (> 4.4.3), this is what solved it for me (I need xboxdrv for moonlight game streaming):

First of all, run xboxdrv as root, if possible.
Then it seems that on newer kernels the standard value of the kernel parameter “dwc_otg.fiq_fsm_mask” has changed from 0x7 (on 4.4.3) to 0x15.
“dwc_otg” is the USB driver and changing the value of “dwc_otg.fiq_fsm_mask” can help with certain USB problems I have read and could be the reason for the xboxdrv error.
More Info

So either downgrade the kernel to 4.4.3 (thats what I did for a couple of months),

or edit /boot/cmdline.txt:

sudo nano /boot/cmdline.txt

Add the line:

dwc_otg.fiq_fsm_mask=0x7

Then reboot.

Thanks for the update.

I’ll give it a try thanks :slight_smile: