April update xboxdrv not working

xboxdrv has told you the error. You need to blacklist the xpad module. Search if you are unsure how to do this.

Hi sam

I have blacklisted xpad which still gives same error as above. When i try the --detach-kernel-driver option its gives LIBUSB_ERROR_NOT_FOUND.

I posted on retrosmc forum see if anyone has any advice.

Type ‘LIBUSB_ERROR_NOT_FOUND’ in the search bar and check the results

I know this thread is old, but if anyone still has the LIBUSB_TRANSFER_ERROR on newer kernels (> 4.4.3), this is what solved it for me (I need xboxdrv for moonlight game streaming):

First of all, run xboxdrv as root, if possible.
Then it seems that on newer kernels the standard value of the kernel parameter “dwc_otg.fiq_fsm_mask” has changed from 0x7 (on 4.4.3) to 0x15.
“dwc_otg” is the USB driver and changing the value of “dwc_otg.fiq_fsm_mask” can help with certain USB problems I have read and could be the reason for the xboxdrv error.
More Info

So either downgrade the kernel to 4.4.3 (thats what I did for a couple of months),

or edit /boot/cmdline.txt:

sudo nano /boot/cmdline.txt

Add the line:


Then reboot.

Thanks for the update.

I’ll give it a try thanks :slight_smile: