Apt-get GPG error

Hi i get this error when i want to do a “apt-get update”

W: GPG error: http://apt.osmc.tv stretch InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 553B25A766C762CC

i then try:
wget [http://apt.osmc.tv/apt.key
gpg --import apt.key
gpg --send-keys 553B25A766C762CC
gpg --keyserver http://keys.gnupg.net --recv-key 553B25A766C762CC
gpg -a --export 553B25A766C762CC | apt-key add

but i get:
gpg: requesting key 66C762CC from http server keys.gnupg.net
gpgkeys: no key data found for http://keys.gnupg.net/
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0

Any advice? (i want to update because i have a problem with the CEC, every time i turn on my AVR the source is automatic changed to OSMC (RPI2)


To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Thanks Tom.

Thank you for the fast reply

i will try this when the kids moves away from tv :slight_smile:

Hmm i tried to update the cec-utils just to make sure it was up to date, and now i really can’t reproduce the issue. so maybe it is fixes, i will continue to test.

If you had run apt-key list, you should have seen a list of the Debian APT keys, plus one OSMC key:

pub   rsa2048 2014-06-06 [SC]
      8735 6F38 CC15 53D2 3E8A  E1E1 553B 25A7 66C7 62CC
uid           [ unknown] Sam G Nazarko <email@samnazarko.co.uk>
sub   rsa2048 2014-06-06 [E]

(You can refer to it as 553B25A766C762CC but 66C762CC will usually be enough to identify it uniquely, eg: apt-key export 66C762CC.

If it wasn’t originally there, you probably fixed your issue with these two commands:

gpg --import apt.key
gpg -a --export 553B25A766C762CC | apt-key add

which was a roundabout way of running apt-key add apt.key'. :wink: (I assume you were running the commands as root.)

Thank you all for the help so far. Problem still persists.

This is from my openhab log:
2018-09-15 11:05:15.962 [INFO ] [runtime.busevents ] - DenonInput state updated to DVD
2018-09-15 11:05:15.995 [INFO ] [runtime.busevents ] - DenonPower state updated to ON
2018-09-15 11:05:16.019 [INFO ] [runtime.busevents ] - DenonInputDVD state updated to ON
2018-09-15 11:05:16.037 [INFO ] [runtime.busevents ] - DenonInputMplay state updated to OFF
2018-09-15 11:05:21.380 [INFO ] [runtime.busevents ] - DenonInput state updated to MPLAY
2018-09-15 11:05:21.403 [INFO ] [runtime.busevents ] - DenonInputMplay state updated to ON
2018-09-15 11:05:21.444 [INFO ] [runtime.busevents ] - DenonInputDVD state updated to OFF
2018-09-15 11:05:21.462 [INFO ] [runtime.busevents ] - DenonMainZone state updated to ON

I press the remote Source DVD and the Denon turns on, when it is powered on it changes to OSMC.

Suggest you open a new thread not to confuse with your apt key problem.
For CEC cec-utils don’t play a role so that wouldn’t have changed anything.
Did you disable “switch active source” in the CEC settings?

Hey fzinken, thank you for the suggestion, i will open a new thread, yes it is disabeled.

If you don’t use CEC at all, just disable it entirely

I use it for volume :slight_smile: nothing else