Archer T4UH USB wifi adaptor not recognised


I have a TP-Pink Archer T4UH AC1200 USB adaptor.

When plugged into my OSMC raspberry pi, dmesg gives me:

[ 2008.664697] usb 1-1.2: USB disconnect, device number 9
[ 2010.695437] usb 1-1.2: new high-speed USB device number 10 using dwc_otg
[ 2010.796422] usb 1-1.2: New USB device found, idVendor=2357, idProduct=0103
[ 2010.796456] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2010.796473] usb 1-1.2: Product: 802.11n NIC
[ 2010.796489] usb 1-1.2: Manufacturer: Realtek
[ 2010.796505] usb 1-1.2: SerialNumber: 123456

The chipset for this is 8812au, but even modprobing that driver doesn’t give me a network interface for the adaptor.

I have run all the updates for osmc.

When I go into myOSMC / Networking, the adaptor doesn’t appear as a wireless option.

I note that states that “USB ID not yet observed in any mainline kernel / this list” - so tried adding to /var/lib/usbutils/usb.ids but the only thing that does is give it a name when I list the usb devices:

Bus 001 Device 010: ID 2357:0103 TPLINK TP-LINK Archer T4UH Wifi Adaptor

Still no wifi interface coming up though.

As the 8812au driver is in the kernel, what else do I need to do to get this adaptor to work ?

Any help appreciated

PS: Originally posted that as a reply to an older thread (Enable wifi under GUI - #58) but then deleted it to post as a new thread. Apologies for the duplicate if this causes any problems.

Hello Pete,

If you can confirm these steps work, I can add support in a future update:

sudo -s
modprobe 8812au
echo 2357 0103 > /sys/bus/usb/rtl8812au/new_id

Hi Sam

Thanks for the rapid reply.

echo 2357 0103 > /sys/bus/usb/rtl8812au/new_id
bash: /sys/bus/usb/rtl8812au/new_id: No such file or directory

Did you mean:

echo 2357 0103 > /sys/bus/usb/drivers/rtl8812au/new_id

When I do this, it clobbers my ethernet connection and I have to reboot.


Yes, that is the path I meant.

What do you mean by clobber? Try and run the command with a keyboard attached and see if WiFi becomes configurable under My OSMC -> Network.


Hi Sam.

So I unplugged the ethernet, plugged in the Adaptor, rebooted and then exited Kobi to get to the console.

I run modprobe and then after

echo 2357 0103 > /sys/bus/usb/drivers/rtl8812au/new_id

the raspberry pi just hangs. When doing it from the console with a USB keyboard I see a few screens of error messages before the Pi hangs. Over ssh it just hangs completely.

Should I plug the USB Adaptor in afterwards ?

You need to keep the USB adapter in and have it in before you run the above comands.

The above command will force the device to ‘match’ the 8812au driver, but if it doesn’t really use the 8812au driver, it could cause a crash.

It would be useful if you could take a photo of the error.

Hi Sam

OK here is the photo of the panic.


Hi Sam

Did you need anything else from me to see what is going on with this adaptor ?

BTW - following this: GitHub - abperiasamy/rtl8812AU_8821AU_linux: rtl8812AU_8821AU linux kernel driver for AC1200 (801.11ac) Wireless Dual-Band USB Adapter works perfectly to get the adaptor running under Ubuntu - but that was just a test run before installing it onto the Pi!


That is the driver I originally based off, so it should work. I’ll add some more dongle IDs soon, but without one at hand my ability to resolve this is limited


Is there anything I can do to get better information on the trigger for the kernel panic which may help you ?


I think the crash is caused by forcing the module to try and match. If you’re having success with aforementioned driver, then I will look for commits adding new dongle support and I will add them to our tree.


Yeah - works great under Ubuntu 15.10 - so it looks like it’s the correct chip set etc.

Let me know if I can help in any way.


Any news on this Sam, and if not, what kind of timescale are we talking about?


Ian Sutherland

Hi Ian

I have not had time to look at this yet


Is this relevant?

Add support for TP-Link Archer T4UH AC1200 thanks to @JudgeZarbi

This is from the changelog of OpenELEC Testbuild #0710 for Kodi 16

Found here

Still no support for this adaptor apparently?