Artifacts during high-motion scenes

Anybody else notice issues with video decoding during scenes with lots of high-speed motion? It looks like MPEG decoding artifacts, with high-speed things leaving artifacts behind them.

And just for note, if I playback these same files on my PC, there is no tearing or artifacting. Hardware decoding not as good as software decoding maybe?

You are providing us virtually no diagnostic info to work with here. We can’t possibly provide any meaningful assistance for such an issue without logs.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

1 Like

Yeah, I notice quite a few artifacts especially in scenes with a stationary object in the forefront (subtitles for example) with high speed motion in the back (like fast camera panning). I just chalked it up to hardware decoding, although I have no technical basis for that.

Subtitles wasn’t quite what I meant, although it happens their too. Scenes with opening credits (actor names, etc) with high speed backgrounds is probably the best example I can think of.

It wasn’t meant as a bug report. I’m fairly certain this is simply a result of the hardware decoding chipset not being the best quality. If I was the only one who was experiencing the issue I’d put in a bug report.

Need to know what video codecs you are playing as a starter.
The video pathway is dependent on what you’re playing

Do you have a link to other reports regarding this?

What is the intended outcome? AML SoCs have industry leading motion adaptive deinterlacing algorithms.

Logs would be quite helpful


Why would you even post if not seeking either confirmation or a solution? Logs would be necessary to confirm or solve the issue. It seems a bit petty to show up and complain about a problem and provide no diagnostic details so that it can be addressed.

1 Like

I’d have to go back and see which ones showed it most. It’s not something that typically shows up unless there’s a lot of rapid movement onscreen. Something like a dogfight scene, which is something I recall.

Either way, almost all the stuff I have in my library is 2160p HEVC 10-bit HDR, ripped direct from media with no re-encoding of any kind. If I can find a specific scene in a specific movie to note I’ll get back to you on it.

That’d be handy. I’d assumed this would be something like Live TV which would involve deinterlacing, as we’ve not really had any issues of reports with progressive content.

As always, half the battle is reproducing the issue.


Umm…perhaps because I wanted to see if it’s something specific to me or not? It’s not a COMPLAINT it’s a QUESTION. Perhaps you can learn the difference before jumping down my throat and being all rude about it.

If and when I think it’s a bug worth reporting, I’ll report it. Period. Until then I’m just seeing if anyone else has experienced it. In the meantime back off. I’ll get a bug report IF AND WHEN I think it’s necessary. If you don’t like it, don’t respond to the damned question. I’ll be more than happy to converse strictly with Sam who, unlike you, seems to have some manners.

Exactly, and I know you need more specific info before looking into it. I don’t like to open a formal bug complaint until I’m sure it’s something with the Vero and not my Marantz or Samsung TV, both of which could be causing issues like this if something is off with them.

I’m going to hook up a PC via HDMI to my Marantz and see if I can reproduce it using non-Vero hardware. If the problem stays put then it’s something with my Marantz or the Sammy. If not, I’ll let you know.

As a side note, I don’t know if ActionA works for you or not. If he does, you might want to give him a little lecture on how to not piss off your customers by being a rude jerk to people who are asking questions. If this is the best he can do, you might do well to keep him away from customers. It’ll give your product – which is excellent – a bad name.

It doesn’t look like deinterlacing artifacts to me. I’ve worked in video for a couple of decades. This looks more like MPEG decode artifacts. If I had a crappy TV I’d almost say it was LCD ghosting but that’s not the case here and I only see it when I playback content through the Vero…although to be fair the Vero is the only thing I use to playback 4K content. Live TV is 1080p and the only player I have hooked up is a 1080p Blu-ray.

I’d be curious to see what a software decode would look like, bypassing the hardware decode of the AmLogic but I suspect the CPU in the Vero can’t do realtime 4k decode, can it?

No – it won’t be possible via software.


I watch tons of 4K material on my Vero, and never seen any artifacting. I’m also watching on a huge projector screen so it would be easy to notice. As Sam knows, I notice everything. Heh.

Without more info, this isn’t really going anywhere.

So to answer your original question, without logs, is nope there’s no issue.

1 Like

Indeed. To find out what’s going on, a clip of a video that’s displaying these artifacts would be at least as useful.

Never seen any artifacting with any hevc directly ripped from disc and I’m watching on 3.8m wide screen.


Hooked up a laptop to my Marantz, played a 4k video and got the same artifacting.

Hooked it up directly to the Samsung (bypassing the receiver) and still got the artifacts.

Dug around in the Samsung menus and found all my post-setup customizations had reverted to factory defaults, including the “smooth motion” settings which default to “Auto”. Turned those off (again) and got artifact-free playback from the laptop, then the Vero.

So, it’s not a bug in the Vero (hence no bug report) which is good. Now to find out why my Samsung lost all its settings and calibration.

1 Like

Glad to hear it’s not an issue on our side.
TVs are getting too complicated :slight_smile:

Indeed they are. My Samsung reboots itself every now and then for no apparent reason. It may only happen once or twice a month but I saw in their forums I’m not the only one getting this.

Now if only I could get all my devices to play nice together with HDMI-CEC :slight_smile: . Yet another panacea that’ll never happen :frowning: