Artifacts in video playing 10-bit H.264

I have some content in 10bits H.264 and I see artifacts in the video when playing in the Raspberry PI, but it works fine in Kodi in my laptop and in mplayer.

I have seen posts here talking about this since 2017, at least, and the usual reply is “this is an uncommon format, not supported”, but Kodi supports it fine in my laptop.

Could I suggest a software fallback, if the GPU firmware in the Raspberry PI can’t play it? I can play H.265 via software in my PI, so I guess it could play H.264 just fine, if the video is incompatible with the GPU acceleration.

Just a suggestion, but this is a real issue for me.


10-bit H264 isn’t supported.

I’d be surprised if it works well with software acceleration. Have you tried disabling hardware acceleration?

How can I disable Hardware Acceleration in my PI?


Under Settings → Playback.

I have OSMC configured in spanish. Disabling something that could be translated to english like “Allow to use decoder DRM PRIME”, my CPU tops and playing 10bit H.264 works. I guess it will not be fast enough for fast moving videos, though. I will experiment.

If I left that option enabled but I disable “hardware accelerated DRM PRIME”, video is not shown at all. So I guess that DRM PRIME requires hardware acceleration.

Is official OSMC position that 10 bit H.264 won’t be hardware accelerated EVER?


Understood. Thanks.

Let’s explore ffmpeg transcoding… :grinning:

Not necessarily for Vero devices :slight_smile:

See if you want to improve translations for OSMC.