Artifacts in videos since version 2021.12

Yesterday I updated to the latest version and I encounter the same artifacts of this topic (Artifacts in videos since version 2021.11.2 - #15 by fzinken) but “only” with 4k HDR video, fullHD videos work fine.
I tried to restart but the problem still remain the same.
Sometimes, but not now, it worked putting in configuratiin —> display mode —> windows so the screen remained blue and at the next restart, after disconnecting the power, the playback was done correctly but now, after several attempts, even this trick doesn’t work anymore.
Sorry for my very poor english.
This morning I tried again and it works perfects but after a reboot the problem appears agains. the strange thing is that the first time the vero4k is turned on, the tv starts on the hdmi1 port while vero4k is connected to my Onkyo av and the tv via earc on the hdmi2 port. even after the first installation of the new update, when I started a video the signal was sent to the tv’s hdmi1 and using the remote control I had to select the hdmi2 input on the tv where the av receiver is connected but at least the video was seen correctly. After the first reboot that problem no longer occurred but the artifacts began.
Here the log of this morning:

And here my tv with artifacts:

I’ve tried now after the post of this morning and the video is ok, I shut down and restart again and it worked again. I tried an other time but now the artifacts appeared again also after several shut down.


Can you reproduce the problem from a cold boot?


Yes, but now I solved with a fresh install of the latest version of OSMC. Now it seems to work perfect!

Unfortunately this evening it happend again; I tried a restart but it didn’t work so I tried my little trick (force display mode to window, then disconnect the power) and it did work ok. After the end of the movie I tried to restart the system and again it worked fine.

Now I downgraded Osmc to 18.9 (because this morning after a cold boot the problem was present again) and it seems to work perfect at every restart: for now I’ll use this version that it’s stable for me.
I never had this problem before update to the latest version from the old 18.9 that I used always in the past.

Kodi v18.9 is not supported anymore. We can only provide support for newer versions of OSMC.

If you are experiencing issues with several versions of OSMC this may indicate an issue with the file you are playing


The problem is certainly present in the latest versione of OSMC with ALL of my files that had worked great in the past and now [EDIT (thi is a typing error)when] I downgraded to 18.9; I tried with this old version because there aren’t the latest changes present from the 19th.
Can you suggest me a 19 version without same changes in kernel, player, or something else present in the latest?

I’m not sure what you mean. If you experience the problem with v18.9 and v19 (which use different kernels); it could be related to the file you are playing.

New versions of Kodi and kernel come from August 2021 release and later.

Sorry sam_nazarko, in my previous post I made a mistake: now I’m using the 18.9v and all files are working great!!!