Aspect ratio not correct in mpg2 dvb stream

I have begun having problems with with tv playback from a tvheadend backend displaying in the incorrect aspect ratio through kodi. It only happens with standard definition channels, or rather the mpeg2 SD channels - theres a couple of SD h264 broadcasts i receive and those are fine, as are HD 264 channels. It looks like the video isnt being stretched on screen as it should, despite the channel information showing the correct aspect ratio value in the video status information display thingy.

I don’t recall this being a problem before, but I notice there might be a new video decoder in use in recent updates? If I disable that (or just disable the hardware acceleration, it all works fine, but frame rate suffers badly with SW decoding.

Any other reports of this issue? and if so, anyone know of any fixes?


To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks, logs are at


Adjust display refresh rate: Off

Please try setting this to on or start and stop?

Thanks Tom

no change, still squished image

Kodi changed aspect ratio options for SD playback in V19. Does the info under “6) What do the different options for the ‘Display 4:3 videos as’ setting do?” help any?

yeah the stretch 16:9 option will work for the most part with content is meant to display in that aspect ratio, but then that means 4:3 content get stretched too (which I can counter by setting view mode “stretch 4:3” in video settings during playback.

However, I think my point is: this used to work automatically by detecting the aspect ratio flag in the video stream and rendering the video appropriately but now seems to be broken in this new decoder that is in use - or to be more specific, it is broken when hardware decoding is used. Disabling hardware acceleration fixes everything but means performance is compromised.

This is a shot in the dark, but if you don’t have the SD resolutions whitelisted, could you whitelist them? That way Kodi/hardware decoder (whoever’s fault it is) wouldn’t need to do any scaling and the aspect ratio would be taken care of by the TV, all Kodi would need to do is work out that one of the whitelisted SD resolutions is the best resolution for that video size and switch to it.

tried that, but no joy.

Does changing thr PRIME render method option help?

Also, what do the Video decoder, Pixel format, and Video stream lines say in the player info when playing an SD video (O key on keyboard or probably a menu or option button on the remote).

I took a few pics the other day to show what is happening.
2 different channels: heres what is shows for each using SW mode and HW mode. In both cases, the aspect ratio of the video is correctly detected but the appropriate stretching is only applied with running in SW mode. (one of the channels is a 4:3 programme, the other is 16:9)
It feels like a bug in PRIME to me…
EGL mode crashes on playback.

The video’s aspect ratio calculated in the “Video stream” line is the same for both HW and SW, so the problem is a difference in how videos smaller than 1920x1080 are expanded to fill the screen for HW.

I can’t find any OSMC test builds so you could try LibreElec to see if the same problem happens, with both Direct to Plane and EGM. If it doesn’t work in a released build you could also try a pre-release build from, they have RPi2 (also works for Pi 3) and RPi4 in the name.

It could also be Kodi, I looked around Kodi’s source code and there is a change made which could have have something to do with it which still hasn’t got into a released build yet.

So… er… not much help I’m afraid, unless you’re willing to spend time trying different releases, wait for an OSMC release with Kodi 19.5 or 20, or go back to 18.9.