Astrometadvbt2 - missing Sony adapters

Hello, I am having issues with OSMC tvdongle and it’s DVB-T2/C Sony adapter. After fresh boot system only discovers DVB-T Realtek so apparently when I try to subscribe to any DVB-T2 channel, I get “no free adapter available” message. I have TVheadend set up and configured.
I tried to google and could see that this issue should be fixed by Vero cold reboot, but no matter how I do it, I always boot up with Realtek only.
Tried to shut down Kodi from OSMC menu, tried to unplug it from the mains without graceful shutdown, also tried to remove USB dongle (then OSMC freezes) and put it back (tried both usb slots), but no luck (remote control module works in both usb slots).
I am trying with 5V/2A adapter that was originally with Verok 4K+ and also with spare 5V/3A. Doesn’t seem to bring any difference.

root@osmc:~# dmesg | grep dvb
[ 3.550752] usb 1-2: Product: dvbt2
[ 3.550756] usb 1-2: Manufacturer: astrometadvbt2
[ 8.144510] usb 1-2: dvb_usb_v2: found a ‘OSMC Engineering DVB-T2’ in warm state
[ 8.236135] usb 1-2: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer
[ 8.319187] rc rc1: lirc_dev: driver ir-lirc-codec (dvb_usb_rtl28xxu) registered at minor = 1
[ 8.319203] usb 1-2: dvb_usb_v2: schedule remote query interval to 200 msecs
[ 8.328967] usb 1-2: dvb_usb_v2: ‘OSMC Engineering DVB-T2’ successfully initialized and connected
[ 8.329598] usbcore: registered new interface driver dvb_usb_rtl28xxu

root@osmc:~# dmesg | grep -i realtek
[ 8.255914] rtl2832 0-0010: Realtek RTL2832 successfully attached
[ 8.256121] usb 1-2: DVB: registering adapter 0 frontend 0 (Realtek RTL2832 (DVB-T))…
[ 8.301480] rtl2832_sdr Realtek RTL2832 SDR attached

root@osmc:~# dmesg | grep -i sony

root@osmc:~# ls -la /home/osmc/.hts/tvheadend/input/linuxdvb/adapters/
total 12
drwx------ 2 osmc video 4096 Apr 22 22:53 .
drwx------ 3 osmc video 4096 May 26 2022 …
-rw------- 1 osmc video 613 Apr 22 22:53 9d84dad05c885fe8d8a91db0bf0c47ce
root@osmc:~# su - osmc
osmc@osmc:~$ service tvheadend stop
osmc@osmc:~$ rm -f /home/osmc/.hts/tvheadend/input/linuxdvb/adapters/9d84dad05c885fe8d8a91db0bf0c47ce
osmc@osmc:~$ ls -la ~/.hts/tvheadend/input/linuxdvb/adapters/
total 8
drwx------ 2 osmc video 4096 Apr 23 13:11 .
drwx------ 3 osmc video 4096 May 26 2022 …
osmc@osmc:~$ service tvheadend start
osmc@osmc:~$ ls -la ~/.hts/tvheadend/input/linuxdvb/adapters/
total 12
drwx------ 2 osmc video 4096 Apr 23 13:12 .
drwx------ 3 osmc video 4096 May 26 2022 …
-rw------- 1 osmc video 613 Apr 23 13:12 9d84dad05c885fe8d8a91db0bf0c47ce
root@osmc:~# dmesg | grep -i sony

How are you powering the dongle? You need to use a powered hub.

right, so this won’t work if the dongle is directly in Vero? This used to work in the past, but interestingly I had tv dongle in Vero and the rest of accessories through the hub. Now I decided to get rid of other toys, thinking I can live without the hub, having tv dongle and remote module only. Seems like I was wrong… : )

I am surprised it works at all like that…