Asus RT-N66U + usb disk + wifi = can't find files?

My goal is to reach files on external USB disk connected to Asus RT-N66U router thru WiFi - without any PC on.

Connected the USB disk, and start SAMBA to share it.
My PC finds it, no problems.

But the Raspberry Pi 2 with OSMC RC cant find it. It is connected to internet thru WiFi and router.

OSMC RC finds my PC thru UPnP, sometimes.

When i try to find files thru SMB it finds nothing. Sometimes it comes some message window telling that there are no shared.

Used Google and found some telling that SAMBA is not ready yet.
Some made it work by the following commands, but i have not tried it yet.
sudo apt-get update
sudo apt-get install ftp-app-osmc

Am i doing something work? (not used to WiFi and network)
Or is it OSMC that is not finished?

Thanks :wink:

on the pi goto
file manager > add source > enter “smb://router ip address/path/to/shared/disk”

Checking my router, finds “LAN-IP”

Trying the IP in PC browser. http://ip/RT-N66U-FF70/Seagate_Backup_Plus_Drive
It will show a website

“Settings have been updated. Website will now be updated.
Changes have been made on IP address or port number. You will now be disconnected from the RT-N66U.
To access the settings for the RT-N66U, reconnect the wireless network and use the updated IP address and port number.”

I have tried to restart router.
OSMC answer: Error 2 - fileshare not available.

It enters the usb disk files if i enter “file://///RT-N66U-FF70/Seagate_Backup_Plus_Drive/” in PC browser.

Yes but.

For the most of times i get “Error. Connection timed out”
One time i got “no route” something.

And one time it connected and showed maps. But just once. Frustrating.

It’s an quality router so it should not be unstable.

Use a network cable on to connect the pi to the network, just to rule out wifi problems.

I had the SAME problem. Its ASUS’s FW. Theres a guy “RMerlin” who makes custom firmware for all the ASUS RT-* routers.

Once you install it, hit the factory reset button and redo your SSID, DHCP, etc as he adds new things and the default change. It doesnt take long. I personally wouldn’t go past the version of 374.41 (for the RT-N66U) because the wifi driver he changed in later versions made streaming 720p horrible. The RT-N66U is the only “N” router he still does drivers for, as all the ASUS RT-* routers are “AC” now and have different chipsets. (Lucky for us).
There’s forks off of the 374.41 if you want to go there… if your router gets messed up it should have come with a recovery CD to set it back to day 1. He added nice features like i can dim all those annoying blinking blue lights, i changed the WPS button to toggle the radio on/off, as i thin WPS is insecure… this is the guy that did the Linksys DD-WRT and Tomato so he’s been doing this a lot.

HERE is the link: (main page)
Downloads: My Files
And heres forums on all the ASUSWRT models and issues:

Hope those help… i love my RT-N66U… I would have paid more for an AC one but i have no AC devices.
Good Luck,