Ati Remote Wonder II not working on Raspberry Pi

Hi,

I have been trying to have my ATI Remote Wonder II working with OSMC on my Raspberry but to no avail.
Initially, it was working, but partially: some keys were not working, in particular Ok, which is a bit of problem…

After investigation, I realized ati_remote2 driver was being used by ther kernel to run the remote, which is described as bringing this kind of problems.

I blacklisted ati_remote2 (/etc/modprobe.d/blacklist.conf) .
Since, then, I couldn’t make it work in any other ways.
I tried to use the configurator in OSMC obviously.

I can see the remote on lsusb:

osmc@piosmc-home:~$ lsusb
Bus 001 Device 004: ID 0471:0602 Philips (or NXP) ATI Remote Wonder II Input Device
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

In dmesg:

[ 2080.088180] usb 1-1.4: USB disconnect, device number 4
[ 2082.111425] usb 1-1.4: new full-speed USB device number 5 using dwc_otg
[ 2082.223564] usb 1-1.4: New USB device found, idVendor=0471, idProduct=0602
[ 2082.223588] usb 1-1.4: New USB device strings: Mfr=0, Product=0, SerialNumber=0

But I don’t seem to manage to have lirc use it.
I am beginner in linux.

Any clue of what I sould do next?

Thanks!
Eric

If it is visible as a usb device, then you won’t be using lirc (as that is only available for GPIO connected remote controls), as far as I know.
Derek

Hi Derek,

thanks for feedback; that’s what I believed initally too.

Though, it seems LIRC can, do much more.

To go to the point, one source which I tried to get ideas from is this one : http://ubuntuaddicted.blogspot.fr/2013/05/ati-remote-wonder-and-linux-xbmc.html
going through the steps, I got errors on re-installing LIRC as it seems OSMC already comes with a configured version of it?
See as well http://www.lirc.org/html/atilibusb_driver.html

Besides, in the remote section of OSMC, we have the Remote Wonder (though it’s not exactly the same as mine) and the driver referred to is atilibusb.
This is the driver I am trying to use.

For instance, I tried to force LIRC to use atilibusb (lircd -h atilibusb), but it didn’t seem to have atilibusb kick in.

I am at a loss…

Cheers,
Riko

If you really want to use LIRC, then you’ll have to interface your remote with a suitable ir detecting device plugged into GPIO.
Otherwise the best you can do is utilise whatever comes from the lircevent process which I’ve read (in this forum) handles events from usb remotes.
The lirc stuff is indeed supplied with OSMC.
I fear that, trying to follow those 2 links, you’ll generate a whole heap of trouble for yourself, as you’re definitely not in a Ubuntu context here, and the atiusb driver may cause you problems.
Derek

I have a remote wonder 2, too and gave up in frustration.
I use cec or a universal tv ir remote now.

Thanks.
The thing with lircevent is that is that it will need to get it’s remote events from something…and as the standard driver (ati_remote2 driver) is not functionnal, I need to find another one. This is where atilibusb was coming in, at least I hoped…

I will be trying a bit more… I like the RF aspect of those remotes!

What’s confusing is that it comes in the OSMC settings explicitly.
It gives the (wrong?) impression there’s little missing to have it work!

Cheers,
Riko

The My OSMC -> Remotes section only deals with GPIO IR receivers.

So if you have a GPIO IR receiver for your Pi then yes you can select any remote in My OSMC->Remotes and they will work. (Or any other remote that works with lircd)

However My OSMC remotes does not work with USB connected receivers. In that case its up to you to figure out whether drivers are needed etc.

Some USB based receivers are supported out of the box either by Kodi directly or via Eventlircd (such as the new black OSMC remote) but in either case My OSMC -> Remotes has nothing to do with their configuration.

Ok… I guess I will abandon then!

Thanks anyway.

Riko