Atmos not working on Vero 4k+ (Plex saying it is direct playing)

Hi,

As above.

Just got my Vero 4k+ and have downloaded Plex from the Kodi Addon Repo.

Plex is saying that the video is direct playing:

However, my AVR (Denon X2500H) is saying “M In +DSur” which I believe is just 5.1.

In Vero 4K+ settings I have:

  • Video output to HDMI
  • Resolution as 4k
  • Sync Video and Audio is OFF
  • Audio Passthrough is ON
  • Speaker config is 7.1

Plex I have allowed Direct play and allowed “Original” version to play.

Not really sure what else it could be… my AVR plays Atmos fine from other devices. It comes up on the AVR as “Atmos” when it does so.

Please advise on what to do.

This shouldn’t affect audio, but you need to set the GUI resolution to 1080 instead of 4K. As to the audio problem, please post full debug logs.

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty)
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

1 Like

Go to Settings -> Audio and make sure Expert Settings is on.

Upload a log via My OSMC -> Logs if unsure so we can check your audio settings, but enabling passthrough isn’t sufficient.

1 Like

This audio wiki post sums up everything you should keep in mind and set to get proper passthrough audio via HDMI: Audio hardware and software configuration

Please follow the instructions mentioned there.

1 Like

Thanks guys…

I completely missed the “Advanced” settings level in the menu. Changed this and I was able to let the Vero know that I had a TrueHD capable AVR.

Atmos is now showing!

Thanks again.

1 Like