Atmos true hd and dts hd

Hi Sam and crew,

I have a sonos atmos system and my samsung tv has passthrough and atmos setting. Some files i stream have no atmos unless i turn off dts hd and some i need to turn off dts core. I’ve got passthrough on 2.0, thats still right yeah? I’m not sure if this is a kodi or osmc or a me issue but there does seem to be a problem. Any of your developers have atmos to test it out? Its probably because so much streaming content has virtually everything in it. Is there a way to prefer atmos, id like have dts hd working as most remuxes of older films thats the only option.

Anyway thanks for the hard work


See Audio hardware and software configuration - General - OSMC and ignore lack of Vero V being mentioned. I will fix that shortly.

We have Atmos equipment here.

Are you playing back dual soundtrack video files and just not getting the stream you were expecting? You can change which audio track is playing during playback in the audio settings accessed typically in the bottom right of the OSD that has all the playback controls.

Also if your sound system has support for DTS-MA you shouldn’t have the core option checked as that would be to dump out plain DTS for older systems.

If I recall, Sonos don’t support DTS at all.

So the user could use AC3 transcoding or change channels and rely on LPCM.

A lot of streams have multiple audio tracks, but I know how to select them. It just seems to work sometimes, not others. I’m mainly interested in atmos but sometimes have to fiddle with the dts settings. Also sometimes it needs to be paused or skipped back to get sound again. It seems like a decoder problem but i dont know.



Latest stuff does, i have a beam2 and the arc supports it as well.

I just read

Looks like you get basic DTS but not the enhanced DTS formats…

Can you please upload some logs so we can check your audio configuration?



I would recommend reading through that audio setup guide that Sam linked to in his first response. You shouldn’t have to fiddle with any of the system level audio settings on a file by file basis. The long and short of it is that there is certain formats that your audio device supports and once you enable just those then Kodi will send out what is supported bitstream and decode anything else to LPCM (with an option to re-encode that to AC3 if selected). What your audio device can play shouldn’t be changing depending on what your playing, so changing these settings should not be necessary.

Ok I’ve got all the settings right I’ve had this setup a while now, just not with the vero. I’ve just started a film with atmos truehd and got no sound but paused and unpaused it and it started working. I think it may be an ffmpeg problem on newer kodi builds but I’m not sure how to even see whats going on development side there but maybe one of you could have a quick look. Thanks a lot for helping.

I found this link

This problem with recognizing the bitstream isn’t a common issue and AFAIK it is normally an issue with the decoding device. Can you provide some logs so we can see how you have it currently configured?

Ok how do I go about that? surprisingly never done it before as worked out issues through searching or mine are weird issues that most don’t get.


Didnt know how to make a new log so its really long but at the bottom after a restart theres something about AE_FMT_FLOAT not working then working. Thats after i got it to put out no sound then a pause play and good normal truehd atmos.


Those settings look correct to me. I would suggest to unplug your soundbar from the wall for a minuite and then plug it back in and see if it behaves any better. If not try enabling the keep audio device alive setting or switching the output configuration from best match to optimized.

Without learning everything about it id say its a soundcard driver issue. Samsung. Tv and sonos cant be uncommon, most are here for the best media playback after all.

On taking a second look I don’t see where Sonos says it supports anything other than regular DTS so you might need to adjust for that. Additionally your setup isn’t reporting DTS support…

====================== Audio Cap =================== k3dRrf31
CodingType MaxChannels SamplingFreq SampleSize
PCM, 2 ch, 32/44.1/48 kHz, 16/20/24 bit
AC-3, 6 ch, 32/44.1/48 kHz, MaxBitRate 640kb/s
Dobly_Digital+/ATMOS, 8 ch, 32/44.1/48 kHz, AFCDepValue 0x1
MAT, 8 ch, 48/96/192 kHz, AFCDepValue 0x3
---------------------- Audio Cap END --------------- k3dRrf31

Which may mean that although your Sonos supports DTS your TV does not support passing it through, or else just doesn’t report that it does. Some testing may be needed there to find out what does and doesn’t actually work so you can adjust your settings accordingly.

1 Like

Thanks for all the help I’ll work through the different settings. I’d not had a tv that had passthrough before so just figured it would be the best option and let the beam2 do its thing.

Edit: changing passthrough on the tv to auto turned atmos truehd to just atmos in the sonos app. I think I’ll give up on dts hd happening apparently samsung have dropped support and its only on bluray, most streams have atmos. Now to figure the pause unpause thing with the other settings. Guess its all licensing nonsense.

Indeed it is.